summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-29 08:44:59 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-29 08:44:59 +0000
commit88a421c3fc4bb5e8f83583418fdce8fbd8cfb18f (patch)
treefe0e6048072e55ed7a5594da11e61f78fcd9f5bf /dev-python/blaze
parentinitial import, ebuild by Guillaume Horel in bug #527294 with a few modifica... (diff)
downloadgentoo-2-88a421c3fc4bb5e8f83583418fdce8fbd8cfb18f.tar.gz
gentoo-2-88a421c3fc4bb5e8f83583418fdce8fbd8cfb18f.tar.bz2
gentoo-2-88a421c3fc4bb5e8f83583418fdce8fbd8cfb18f.zip
bump; update deps, currently doc build also fails and my need purging, tidy test & install phase, pmasked until dynd-python and the libs are bumped to 0.6.5 and a plan decided for the doc build
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/blaze')
-rw-r--r--dev-python/blaze/ChangeLog10
-rw-r--r--dev-python/blaze/blaze-0.6.0.ebuild4
-rw-r--r--dev-python/blaze/blaze-0.6.5.ebuild80
3 files changed, 91 insertions, 3 deletions
diff --git a/dev-python/blaze/ChangeLog b/dev-python/blaze/ChangeLog
index 5a6c316118a0..eebd6450ff37 100644
--- a/dev-python/blaze/ChangeLog
+++ b/dev-python/blaze/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/blaze
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.6 2014/09/02 04:13:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.7 2014/10/29 08:44:59 idella4 Exp $
+
+*blaze-0.6.5 (29 Oct 2014)
+
+ 29 Oct 2014; Ian Delaney <idella4@gentoo.org> +blaze-0.6.5.ebuild,
+ blaze-0.6.0.ebuild:
+ bump; update deps, currently doc build also fails and my need purging, tidy
+ test & install phase, pmasked until dynd-python and the libs are bumped to
+ 0.6.5 and a plan decided for the doc build
*blaze-0.6.0 (02 Sep 2014)
diff --git a/dev-python/blaze/blaze-0.6.0.ebuild b/dev-python/blaze/blaze-0.6.0.ebuild
index 419f648808eb..c9d07677c1cb 100644
--- a/dev-python/blaze/blaze-0.6.0.ebuild
+++ b/dev-python/blaze/blaze-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.6.0.ebuild,v 1.1 2014/09/02 04:13:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.6.0.ebuild,v 1.2 2014/10/29 08:44:59 idella4 Exp $
EAPI=5
@@ -49,7 +49,7 @@ python_compile_all() {
python_test() {
cd "${BUILD_DIR}"/lib || die
- ${PYTHON} -c 'import blaze; blaze.test()' || die
+ "${PYTHON}" -c 'import blaze; blaze.test()' || die
}
python_install_all() {
diff --git a/dev-python/blaze/blaze-0.6.5.ebuild b/dev-python/blaze/blaze-0.6.5.ebuild
new file mode 100644
index 000000000000..f8a8db875b97
--- /dev/null
+++ b/dev-python/blaze/blaze-0.6.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.6.5.ebuild,v 1.1 2014/10/29 08:44:59 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation Python numpy"
+HOMEPAGE="http://blaze.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# Currently doc build fails, reason unclear but appears it's tied to use of
+# redhat's anaconda installer, seemingly hostile to gentoo.
+# Leaving doc build content in case this is fixed
+IUSE="doc examples test"
+
+# pyspark appears an optional dep not in portage. pyskit appears to be dropped
+# pyparsing lokks to be required still despite its absence from requirements.txt
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND="
+ >=dev-python/blz-0.6.2[${PYTHON_USEDEP}]
+ ~dev-python/datashape-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/cytoolz[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PY2_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PY2_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ >=dev-python/cython-0.18[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/bokeh[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )
+ "
+# Currently doc build fails, reason unclear but appears it's tied to use of
+# redhat's anaconda installer, seemingly hostile to gentoo.
+
+python_prepare_all() {
+ # Prevent d'loading. Use this for now. Flagged for improved fix later.
+ sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ # https://github.com/ContinuumIO/blaze/issues/791
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -c 'import blaze; blaze.test()' || die
+}
+
+python_install_all() {
+# use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}