summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 17:31:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 17:31:24 +0000
commitd2873a331fe00eeac189e79b8e0ad3fc3b96a545 (patch)
tree0f69845ac8ac69b1202d6808d46ba256988f48c6 /dev-python/blinker/blinker-1.1.ebuild
parentstable x86, bug 354237 (diff)
downloadgentoo-2-d2873a331fe00eeac189e79b8e0ad3fc3b96a545.tar.gz
gentoo-2-d2873a331fe00eeac189e79b8e0ad3fc3b96a545.tar.bz2
gentoo-2-d2873a331fe00eeac189e79b8e0ad3fc3b96a545.zip
Initial addition.
(Portage version: 2.2.0_alpha23_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/blinker/blinker-1.1.ebuild')
-rw-r--r--dev-python/blinker/blinker-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/blinker/blinker-1.1.ebuild b/dev-python/blinker/blinker-1.1.ebuild
new file mode 100644
index 000000000000..d6cf0f73a932
--- /dev/null
+++ b/dev-python/blinker/blinker-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blinker/blinker-1.1.ebuild,v 1.1 2011/02/12 17:31:24 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="http://discorporate.us/projects/Blinker/ http://pypi.python.org/pypi/blinker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}