summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-28 04:46:47 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-28 04:46:47 +0000
commit712c71fd3b1ae3c3875c7b369c21a5414f2a61be (patch)
tree5b0c8c642c44047c76267485e8bf9902a130c48f /dev-python/boto
parentBump (diff)
downloadgentoo-2-712c71fd3b1ae3c3875c7b369c21a5414f2a61be.tar.gz
gentoo-2-712c71fd3b1ae3c3875c7b369c21a5414f2a61be.tar.bz2
gentoo-2-712c71fd3b1ae3c3875c7b369c21a5414f2a61be.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.26.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index a8b77de270ec..c2faf2e43e4a 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.91 2014/02/24 22:31:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.92 2014/02/28 04:46:47 radhermit Exp $
+
+*boto-2.26.0 (28 Feb 2014)
+
+ 28 Feb 2014; Tim Harder <radhermit@gentoo.org> +boto-2.26.0.ebuild:
+ Version bump.
24 Feb 2014; Mike Frysinger <vapier@gentoo.org> boto-2.25.0.ebuild:
Add arm love for Chromium OS.
diff --git a/dev-python/boto/boto-2.26.0.ebuild b/dev-python/boto/boto-2.26.0.ebuild
new file mode 100644
index 000000000000..6dd24f4b8a9e
--- /dev/null
+++ b/dev-python/boto/boto-2.26.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.26.0.ebuild,v 1.1 2014/02/28 04:46:47 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}