summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 06:29:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 06:29:38 +0000
commitc01210d1340bfa9cb012b11591e31d7dd1f2a1bd (patch)
treea881a45e795f22faca61028b8db3f0ded343d575 /dev-python/bpython
parentStable for HPPA (bug #292132). (diff)
downloadgentoo-2-c01210d1340bfa9cb012b11591e31d7dd1f2a1bd.tar.gz
gentoo-2-c01210d1340bfa9cb012b11591e31d7dd1f2a1bd.tar.bz2
gentoo-2-c01210d1340bfa9cb012b11591e31d7dd1f2a1bd.zip
Fix traceback with Python 3.
(Portage version: 14821-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/ChangeLog8
-rw-r--r--dev-python/bpython/bpython-0.9.5.2-r1.ebuild28
-rw-r--r--dev-python/bpython/files/bpython-0.9.5.2-python-3.patch11
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/bpython/ChangeLog b/dev-python/bpython/ChangeLog
index 34f4d3fcb3bb..98fd843a517a 100644
--- a/dev-python/bpython/ChangeLog
+++ b/dev-python/bpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/bpython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.11 2009/10/02 01:51:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/ChangeLog,v 1.12 2009/11/15 06:29:38 arfrever Exp $
+
+*bpython-0.9.5.2-r1 (15 Nov 2009)
+
+ 15 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +bpython-0.9.5.2-r1.ebuild, +files/bpython-0.9.5.2-python-3.patch:
+ Fix traceback with Python 3.
*bpython-0.9.5.2 (02 Oct 2009)
diff --git a/dev-python/bpython/bpython-0.9.5.2-r1.ebuild b/dev-python/bpython/bpython-0.9.5.2-r1.ebuild
new file mode 100644
index 000000000000..5f4e21786eff
--- /dev/null
+++ b/dev-python/bpython/bpython-0.9.5.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bpython/bpython-0.9.5.2-r1.ebuild,v 1.1 2009/11/15 06:29:38 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="ncurses"
+
+inherit distutils eutils
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ http://pypi.python.org/pypi/bpython"
+SRC_URI="http://www.bpython-interpreter.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygments
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="sample-config sample.theme light.theme"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-3.patch"
+}
diff --git a/dev-python/bpython/files/bpython-0.9.5.2-python-3.patch b/dev-python/bpython/files/bpython-0.9.5.2-python-3.patch
new file mode 100644
index 000000000000..6142c9ed3f67
--- /dev/null
+++ b/dev-python/bpython/files/bpython-0.9.5.2-python-3.patch
@@ -0,0 +1,11 @@
+--- bpython/importcompletion.py
++++ bpython/importcompletion.py
+@@ -77,7 +77,7 @@
+ name = os.path.splitext(name)[0]
+ try:
+ fo, pathname, _ = imp.find_module(name, [path])
+- except ImportError:
++ except (ImportError, SyntaxError):
+ continue
+ else:
+ if fo is not None: