summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 18:43:41 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 18:43:41 +0000
commit108d836bcdcf936588cbf075c63f3b3950fd785b (patch)
tree566408d2cf16411675854930b267843b4523e8f8 /dev-python/brasero-python
parentDrop media-libs/giblib dependency per #511418 (diff)
downloadgentoo-2-108d836bcdcf936588cbf075c63f3b3950fd785b.tar.gz
gentoo-2-108d836bcdcf936588cbf075c63f3b3950fd785b.tar.bz2
gentoo-2-108d836bcdcf936588cbf075c63f3b3950fd785b.zip
Convert to gnome-python-common-r1. Fix dependencies.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/brasero-python')
-rw-r--r--dev-python/brasero-python/ChangeLog11
-rw-r--r--dev-python/brasero-python/brasero-python-2.32.0-r1.ebuild24
2 files changed, 32 insertions, 3 deletions
diff --git a/dev-python/brasero-python/ChangeLog b/dev-python/brasero-python/ChangeLog
index 678733452e28..6e4efe424f2d 100644
--- a/dev-python/brasero-python/ChangeLog
+++ b/dev-python/brasero-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/brasero-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/brasero-python/ChangeLog,v 1.24 2011/03/23 20:25:22 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/brasero-python/ChangeLog,v 1.25 2014/05/26 18:43:41 mgorny Exp $
+
+*brasero-python-2.32.0-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +brasero-python-2.32.0-r1.ebuild:
+ Convert to gnome-python-common-r1. Fix dependencies.
23 Mar 2011; Gilles Dartiguelongue <eva@gentoo.org>
-brasero-python-2.30.2.ebuild:
@@ -94,4 +100,3 @@
29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+brasero-python-2.28.0.ebuild, +metadata.xml:
Initial ebuild for GNOME 2.28.
-
diff --git a/dev-python/brasero-python/brasero-python-2.32.0-r1.ebuild b/dev-python/brasero-python/brasero-python-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..0d945211e5aa
--- /dev/null
+++ b/dev-python/brasero-python/brasero-python-2.32.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/brasero-python/brasero-python-2.32.0-r1.ebuild,v 1.1 2014/05/26 18:43:41 mgorny Exp $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python-desktop"
+G_PY_BINDINGS=( braseroburn braseromedia )
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1
+
+DESCRIPTION="Python bindings for Brasero CD/DVD burning"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND="<app-cdr/brasero-3
+ >=app-cdr/brasero-2.29
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/braseroburn/. examples/braseromedia/. )