summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-30 04:07:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-30 04:07:25 +0000
commit7a8a4606ac87f7a6b4f327761a880c1cb2a2524d (patch)
treec4e21646ca07fd4ccaec5d0f421c39647afbf477 /dev-python/cairocffi
parentVersion bump. (diff)
downloadgentoo-2-7a8a4606ac87f7a6b4f327761a880c1cb2a2524d.tar.gz
gentoo-2-7a8a4606ac87f7a6b4f327761a880c1cb2a2524d.tar.bz2
gentoo-2-7a8a4606ac87f7a6b4f327761a880c1cb2a2524d.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cairocffi')
-rw-r--r--dev-python/cairocffi/ChangeLog7
-rw-r--r--dev-python/cairocffi/cairocffi-0.5.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/cairocffi/ChangeLog b/dev-python/cairocffi/ChangeLog
index 1baf3d7900f8..d9182cfb195c 100644
--- a/dev-python/cairocffi/ChangeLog
+++ b/dev-python/cairocffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cairocffi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/ChangeLog,v 1.4 2014/05/08 22:20:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/ChangeLog,v 1.5 2014/05/30 04:07:25 idella4 Exp $
+
+*cairocffi-0.5.4 (30 May 2014)
+
+ 30 May 2014; Ian Delaney <idella4@gentoo.org> +cairocffi-0.5.4.ebuild:
+ bump
*cairocffi-0.5.3-r1 (08 May 2014)
diff --git a/dev-python/cairocffi/cairocffi-0.5.4.ebuild b/dev-python/cairocffi/cairocffi-0.5.4.ebuild
new file mode 100644
index 000000000000..22ee31b17bee
--- /dev/null
+++ b/dev-python/cairocffi/cairocffi-0.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/cairocffi-0.5.4.ebuild,v 1.1 2014/05/30 04:07:25 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
+MY_PN="${PN}"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/SimonSapin/cairocffi"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ x11-libs/cairo:0="
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test ${PN}/ || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}