summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCorentin Chary <iksaif@gentoo.org>2013-03-06 09:16:20 +0000
committerCorentin Chary <iksaif@gentoo.org>2013-03-06 09:16:20 +0000
commitea871843cf864f9889e70a1ed25a6b66d6355fe8 (patch)
treebef86a770a4e650409015959d299e460f0299938 /dev-python/celery
parentSecurity bump. #460360 (diff)
downloadgentoo-2-ea871843cf864f9889e70a1ed25a6b66d6355fe8.tar.gz
gentoo-2-ea871843cf864f9889e70a1ed25a6b66d6355fe8.tar.bz2
gentoo-2-ea871843cf864f9889e70a1ed25a6b66d6355fe8.zip
Fix 'status' action in init script and remove some old ebuilds.
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/ChangeLog9
-rw-r--r--dev-python/celery/celery-3.0.11-r1.ebuild94
-rw-r--r--dev-python/celery/celery-3.0.14-r1.ebuild (renamed from dev-python/celery/celery-3.0.14.ebuild)2
-rw-r--r--dev-python/celery/celery-3.0.9.ebuild88
-rw-r--r--dev-python/celery/files/celery.initd7
5 files changed, 13 insertions, 187 deletions
diff --git a/dev-python/celery/ChangeLog b/dev-python/celery/ChangeLog
index 3b844bdc6312..5f45b14bb01f 100644
--- a/dev-python/celery/ChangeLog
+++ b/dev-python/celery/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/celery
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.17 2013/02/22 08:20:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.18 2013/03/06 09:16:20 iksaif Exp $
+
+*celery-3.0.14-r1 (06 Mar 2013)
+
+ 06 Mar 2013; Corentin Chary <iksaif@gentoo.org> +celery-3.0.14-r1.ebuild,
+ -celery-3.0.11-r1.ebuild, -celery-3.0.14.ebuild, -celery-3.0.9.ebuild,
+ files/celery.initd:
+ Fix 'status' action in init script and remove some old ebuilds.
*celery-3.0.14 (22 Feb 2013)
diff --git a/dev-python/celery/celery-3.0.11-r1.ebuild b/dev-python/celery/celery-3.0.11-r1.ebuild
deleted file mode 100644
index c5329cc58be6..000000000000
--- a/dev-python/celery/celery-3.0.11-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.11-r1.ebuild,v 1.3 2013/01/06 19:26:45 mgorny Exp $
-
-EAPI="4"
-
-# Not broken but unsupported; dev-python/redis-py doesn't
-# support python3 which is a dep in tests. pypy fails just 1 test
-PYTHON_TESTS_RESTRICTED_ABIS="3.* 2.7-pypy-*"
-PYTHON_DEPEND="*:2.7"
-RESTRICT_PYTHON_ABIS="2.[5-6]"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
-HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples sql test"
-
-# jython would need: threadpool, simplejson
-# python2.5 would need: ordereddict, test? unittest2
-# python2.6 would need: multiprocessing, test? simplejson
-RDEPEND=">=dev-python/kombu-2.4.7
- <dev-python/kombu-3.0
- sql? ( dev-python/sqlalchemy )
- dev-python/python-dateutil
- >=dev-python/anyjson-0.3.3
- virtual/pyparsing
- >=dev-python/billiard-2.7.3.17
- dev-python/pytz
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/gevent
- >=dev-python/mock-0.7.0
- virtual/python-unittest2
- dev-python/pyopenssl
- dev-python/nose-cover3
- dev-python/sqlalchemy
- dev-python/pymongo
- dev-python/redis-py
- dev-db/redis
- )
- doc? (
- dev-python/docutils
- dev-python/sphinx
- dev-python/jinja
- dev-python/sphinxcontrib-issuetracker
- dev-python/sqlalchemy
- )
- dev-python/setuptools"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-require-python-dateutil-2.1.patch"
-}
-
-src_test() {
- testing() {
- nosetests --py3where build-${PYTHON_ABI}/lib/${PN}/tests
- }
- python_execute_function testing
-}
-
-src_compile() {
- distutils_src_compile
- dodocs() {
- echo "test $PYTHON_ABI"
- if [[ "${PYTHON_ABI}" == "2.7" ]]; then
- mkdir docs/.build || die
- PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C docs html
- fi
- }
- use doc && python_execute_function dodocs
-}
-
-src_install() {
- distutils_src_install --install-scripts="/usr/bin"
-
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd" celery
- newconfd "${FILESDIR}/celery.confd" celery
-
- if use examples; then
- insinto usr/share/doc/${P}/
- doins -r examples
- fi
- use doc && dohtml -r docs/.build/html/
-}
diff --git a/dev-python/celery/celery-3.0.14.ebuild b/dev-python/celery/celery-3.0.14-r1.ebuild
index 930e647ebfd4..4ddca490c851 100644
--- a/dev-python/celery/celery-3.0.14.ebuild
+++ b/dev-python/celery/celery-3.0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.14.ebuild,v 1.1 2013/02/22 08:20:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.14-r1.ebuild,v 1.1 2013/03/06 09:16:20 iksaif Exp $
EAPI="4"
diff --git a/dev-python/celery/celery-3.0.9.ebuild b/dev-python/celery/celery-3.0.9.ebuild
deleted file mode 100644
index 92f66c71e518..000000000000
--- a/dev-python/celery/celery-3.0.9.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.9.ebuild,v 1.2 2012/12/31 12:58:43 mgorny Exp $
-
-EAPI="4"
-
-# Not broken but unsupported; dev-python/redis-py doesn't
-# support python3 which is a dep in tests. pypy fails just 1 test
-PYTHON_TESTS_RESTRICTED_ABIS="3.* 2.7-pypy-*"
-PYTHON_DEPEND="*:2.7"
-RESTRICT_PYTHON_ABIS="2.[5-6]"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
-HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples sql test"
-
-# jython would need: threadpool, simplejson
-# python2.5 would need: ordereddict, test? unittest2
-# python2.6 would need: multiprocessing, test? simplejson
-RDEPEND=">=dev-python/kombu-2.2.5
- <dev-python/kombu-3.0
- sql? ( dev-python/sqlalchemy )
- dev-python/python-dateutil
- >=dev-python/anyjson-0.3.3
- virtual/pyparsing
- >=dev-python/billiard-2.7.3.12
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/gevent
- >=dev-python/mock-0.7.0
- dev-python/pyopenssl
- dev-python/nose-cover3
- dev-python/sqlalchemy
- dev-python/pymongo
- dev-python/redis-py
- dev-db/redis
- )
- doc? (
- dev-python/docutils
- dev-python/sphinx
- dev-python/jinja
- dev-python/sphinxcontrib-issuetracker
- dev-python/sqlalchemy
- )
- dev-python/setuptools"
-
-src_test() {
- testing() {
- nosetests --py3where build-${PYTHON_ABI}/lib/${PN}/tests
- }
- python_execute_function testing
-}
-
-src_compile() {
- distutils_src_compile
- dodocs() {
- echo "test $PYTHON_ABI"
- if [[ "${PYTHON_ABI}" == "2.7" ]]; then
- mkdir docs/.build || die
- PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C docs html
- fi
- }
- use doc && python_execute_function dodocs
-}
-
-src_install() {
- distutils_src_install --install-scripts="/usr/bin"
-
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd" celery
- newconfd "${FILESDIR}/celery.confd" celery
-
- if use examples; then
- insinto usr/share/doc/${P}/
- doins -r examples
- fi
- use doc && dohtml -r docs/.build/html/
-}
diff --git a/dev-python/celery/files/celery.initd b/dev-python/celery/files/celery.initd
index 34515b7068b0..fe278df19a3b 100644
--- a/dev-python/celery/files/celery.initd
+++ b/dev-python/celery/files/celery.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the BSD license
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/files/celery.initd,v 1.4 2013/02/09 13:49:36 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/files/celery.initd,v 1.5 2013/03/06 09:16:20 iksaif Exp $
extra_started_commands="reload"
@@ -30,7 +30,7 @@ export CELERY_LOADER
if yesno "$CELERY_DJANGO"; then
CELERYD=${CELERYD:-"celeryd_detach"}
- CELERYCTL=${CELERYCTL:-"python manage.py celeryd"}
+ CELERYCTL=${CELERYCTL:-"python manage.py celery"}
CELERYD_MULTI=${CELERYD_MULTI:-"python manage.py celeryd_multi"}
CELERYBEAT=${CELERYBEAT:-"python manage.py celerybeat"}
CELERYEV=${CELERYEV:-"python manage.py celeryev"}
@@ -263,5 +263,6 @@ reload() {
status() {
checkconfig || return 1
- ${CELERYCTL} status
+ celery_chdir && \
+ ${CELERYCTL} status
}