summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-07-08 03:20:58 +0000
committerTim Harder <radhermit@gentoo.org>2014-07-08 03:20:58 +0000
commitb2d3057d38a47bbc7b77d3085ec7ca22e79c5494 (patch)
tree7f9aecd9348e8e18d64894a69beb39f800109d88 /dev-python/cffi
parentVersion bump. (diff)
downloadgentoo-2-b2d3057d38a47bbc7b77d3085ec7ca22e79c5494.tar.gz
gentoo-2-b2d3057d38a47bbc7b77d3085ec7ca22e79c5494.tar.bz2
gentoo-2-b2d3057d38a47bbc7b77d3085ec7ca22e79c5494.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-0.8.6.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index 50db5b6c8181..046158be4185 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.35 2014/06/23 11:12:13 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.36 2014/07/08 03:20:58 radhermit Exp $
+
+*cffi-0.8.6 (08 Jul 2014)
+
+ 08 Jul 2014; Tim Harder <radhermit@gentoo.org> +cffi-0.8.6.ebuild:
+ Version bump.
23 Jun 2014; Tobias Klausmann <klausman@gentoo.org> cffi-0.8.2.ebuild:
Dekeywording on alpha due to ply being broken (bug 514446) which dekeywords
diff --git a/dev-python/cffi/cffi-0.8.6.ebuild b/dev-python/cffi/cffi-0.8.6.ebuild
new file mode 100644
index 000000000000..0f7096c7620b
--- /dev/null
+++ b/dev-python/cffi/cffi-0.8.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.6.ebuild,v 1.1 2014/07/08 03:20:58 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code."
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/build/
+}