summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-04-29 02:03:25 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-04-29 02:03:25 +0000
commitcd2e2db623672ffe39c6c7eef99ceed64a4710ce (patch)
tree6dedc9b852719e60434fefc1b7b8354bc8a5aa03 /dev-python/cherrypy
parentfix scragged header (diff)
downloadgentoo-2-cd2e2db623672ffe39c6c7eef99ceed64a4710ce.tar.gz
gentoo-2-cd2e2db623672ffe39c6c7eef99ceed64a4710ce.tar.bz2
gentoo-2-cd2e2db623672ffe39c6c7eef99ceed64a4710ce.zip
Version bump. #Closes 219485
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/ChangeLog7
-rw-r--r--dev-python/cherrypy/cherrypy-3.0.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index 7b6d14f0cab8..d707c8d4ffab 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.27 2008/01/09 14:55:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.28 2008/04/29 02:03:25 pythonhead Exp $
+
+*cherrypy-3.0.3 (29 Apr 2008)
+
+ 29 Apr 2008; Rob Cakebread <pythonhead@gentoo.org> +cherrypy-3.0.3.ebuild:
+ Version bump. #Closes 219485
09 Jan 2008; Raúl Porcel <armin76@gentoo.org> cherrypy-2.2.1-r2.ebuild:
ia64/x86 stable wrt security #204829
diff --git a/dev-python/cherrypy/cherrypy-3.0.3.ebuild b/dev-python/cherrypy/cherrypy-3.0.3.ebuild
new file mode 100644
index 000000000000..71106d700dcf
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.0.3.ebuild,v 1.1 2008/04/29 02:03:25 pythonhead Exp $
+
+inherit eutils distutils
+
+MY_P=CherryPy-${PV}
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
+SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cherrypy.org/"
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+LICENSE="BSD"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/"cherrypy.tutorial",//' \
+ -e "/('cherrypy\/tutorial',/, /),/d" \
+ setup.py || die "sed failed"
+
+}
+
+src_install() {
+ distutils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r cherrypy/tutorial
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" cherrypy/test/test.py --dumb || die "test failed"
+}