summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-08-01 05:38:49 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-08-01 05:38:49 +0000
commit924b1ceb8b49f94e39b248aa6bcc8f35520fb628 (patch)
tree32257b9df38236e545ff83b17ce3be0f7f89fcd7 /dev-python/cliff
parentBump (diff)
downloadgentoo-2-924b1ceb8b49f94e39b248aa6bcc8f35520fb628.tar.gz
gentoo-2-924b1ceb8b49f94e39b248aa6bcc8f35520fb628.tar.bz2
gentoo-2-924b1ceb8b49f94e39b248aa6bcc8f35520fb628.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/ChangeLog8
-rw-r--r--dev-python/cliff/cliff-1.4.5.ebuild34
-rw-r--r--dev-python/cliff/cliff-1.4.ebuild35
-rw-r--r--dev-python/cliff/cliff-1.6.1.ebuild37
4 files changed, 44 insertions, 70 deletions
diff --git a/dev-python/cliff/ChangeLog b/dev-python/cliff/ChangeLog
index 4bf05cff2234..bd0002b6d1c5 100644
--- a/dev-python/cliff/ChangeLog
+++ b/dev-python/cliff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cliff
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.10 2014/07/06 12:40:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.11 2014/08/01 05:38:48 prometheanfire Exp $
+
+*cliff-1.6.1 (01 Aug 2014)
+
+ 01 Aug 2014; Matthew Thode <prometheanfire@gentoo.org> +cliff-1.6.1.ebuild,
+ -cliff-1.4.5.ebuild, -cliff-1.4.ebuild:
+ bup
06 Jul 2014; Michał Górny <mgorny@gentoo.org> cliff-1.4.5.ebuild,
cliff-1.4.ebuild:
diff --git a/dev-python/cliff/cliff-1.4.5.ebuild b/dev-python/cliff/cliff-1.4.5.ebuild
deleted file mode 100644
index 5a5ca9a047f8..000000000000
--- a/dev-python/cliff/cliff-1.4.5.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.4.5.ebuild,v 1.3 2014/07/06 12:40:19 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/dreamhost/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/pep8[${PYTHON_USEDEP}]
- dev-python/cmd2[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cliff/cliff-1.4.ebuild b/dev-python/cliff/cliff-1.4.ebuild
deleted file mode 100644
index f6a1ccbc7bc6..000000000000
--- a/dev-python/cliff/cliff-1.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.4.ebuild,v 1.6 2014/07/06 12:40:19 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/dreamhost/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="<dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
- >=dev-python/cmd2-0.6.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e '29,37d' "setup.py" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cliff/cliff-1.6.1.ebuild b/dev-python/cliff/cliff-1.6.1.ebuild
new file mode 100644
index 000000000000..7d4621d3a73b
--- /dev/null
+++ b/dev-python/cliff/cliff-1.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.6.1.ebuild,v 1.1 2014/08/01 05:38:48 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ !~dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}