summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-10 09:18:48 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-10 09:18:48 +0000
commit32c19e8e4519f02bfcc16ac97af5d26334b55e4a (patch)
treebbd60bcd6b5565d8208cbc3eb4a9f681c822e1ed /dev-python/dbus-python
parentfix #444726, #445930, #446668 (diff)
downloadgentoo-2-32c19e8e4519f02bfcc16ac97af5d26334b55e4a.tar.gz
gentoo-2-32c19e8e4519f02bfcc16ac97af5d26334b55e4a.tar.bz2
gentoo-2-32c19e8e4519f02bfcc16ac97af5d26334b55e4a.zip
Update to python-r1.eclass and EAPI5.
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog8
-rw-r--r--dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 0955565788b0..75174d040d19 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.107 2012/10/14 15:00:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.108 2012/12/10 09:18:48 tetromino Exp $
+
+*dbus-python-1.1.1-r1 (10 Dec 2012)
+
+ 10 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +dbus-python-1.1.1-r1.ebuild:
+ Update to python-r1.eclass and EAPI5.
14 Oct 2012; Raúl Porcel <armin76@gentoo.org> dbus-python-1.1.1.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #416725
diff --git a/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild b/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..ab305c79e608
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild,v 1.1 2012/12/10 09:18:48 tetromino Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit eutils python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100:=
+ >=sys-apps/dbus-1.6:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( =dev-python/epydoc-3* )
+ test? ( dev-python/pygobject:3 )"
+# TODO: should be dev-python/pygobject:3[${PYTHON_USEDEP]
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-html-docs \
+ $(use_enable doc api-docs) \
+ PYTHON_LIBS="$(python-config --ldflags)"
+ # configure assumes that ${PYTHON}-config executable exists :/
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installing() {
+ default
+ use doc && nonfatal dohtml -r api/*
+ }
+ python_foreach_impl run_in_build_dir installing
+ prune_libtool_files --modules
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}