summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-22 01:49:12 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-22 01:49:12 +0000
commit0198730a8272f9d77e5bc4416f5064644cf4c616 (patch)
tree07ab1cf48e509790a8963cc44468346f43fe7527 /dev-python/demjson
parentinitial commit (diff)
downloadgentoo-2-0198730a8272f9d77e5bc4416f5064644cf4c616.tar.gz
gentoo-2-0198730a8272f9d77e5bc4416f5064644cf4c616.tar.bz2
gentoo-2-0198730a8272f9d77e5bc4416f5064644cf4c616.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/demjson')
-rw-r--r--dev-python/demjson/ChangeLog7
-rw-r--r--dev-python/demjson/demjson-2.2.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/demjson/ChangeLog b/dev-python/demjson/ChangeLog
index a35f3199e5c0..13a5b2f11aa2 100644
--- a/dev-python/demjson/ChangeLog
+++ b/dev-python/demjson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/demjson
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/demjson/ChangeLog,v 1.18 2014/05/30 05:22:52 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/demjson/ChangeLog,v 1.19 2014/07/22 01:49:12 idella4 Exp $
+
+*demjson-2.2.2 (22 Jul 2014)
+
+ 22 Jul 2014; Ian Delaney <idella4@gentoo.org> +demjson-2.2.2.ebuild:
+ bump
*demjson-2.0.1 (30 May 2014)
diff --git a/dev-python/demjson/demjson-2.2.2.ebuild b/dev-python/demjson/demjson-2.2.2.ebuild
new file mode 100644
index 000000000000..f064a7c86035
--- /dev/null
+++ b/dev-python/demjson/demjson-2.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/demjson/demjson-2.2.2.ebuild,v 1.1 2014/07/22 01:49:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ http://pypi.python.org/pypi/demjson"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Docs are .txt files
+ if use doc; then
+ dodoc docs/*.txt || die "Installation of documentation failed"
+ fi
+}