summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-03 07:48:21 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-03 07:48:21 +0000
commit22b004511290374a7616ca785a7f5c57ff308cfc (patch)
tree6d62c13058e001b60692137cee870a99ea4af4bb /dev-python/demjson
parentVersion bump, add python3_4 support. (diff)
downloadgentoo-2-22b004511290374a7616ca785a7f5c57ff308cfc.tar.gz
gentoo-2-22b004511290374a7616ca785a7f5c57ff308cfc.tar.bz2
gentoo-2-22b004511290374a7616ca785a7f5c57ff308cfc.zip
bump; add py3 pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/demjson')
-rw-r--r--dev-python/demjson/ChangeLog9
-rw-r--r--dev-python/demjson/demjson-2.0.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/demjson/ChangeLog b/dev-python/demjson/ChangeLog
index 349e23daaf82..25e3e0f3c220 100644
--- a/dev-python/demjson/ChangeLog
+++ b/dev-python/demjson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/demjson
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/demjson/ChangeLog,v 1.16 2011/06/23 14:46:54 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/demjson/ChangeLog,v 1.17 2014/05/03 07:48:21 idella4 Exp $
+
+*demjson-2.0 (03 May 2014)
+
+ 03 May 2014; Ian Delaney <idella4@gentoo.org> +demjson-2.0.ebuild:
+ bump; add py3 pypy support
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -demjson-1.5.ebuild:
Remove old ebuilds. Requested by Arfrever
diff --git a/dev-python/demjson/demjson-2.0.ebuild b/dev-python/demjson/demjson-2.0.ebuild
new file mode 100644
index 000000000000..7ee733567420
--- /dev/null
+++ b/dev-python/demjson/demjson-2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/demjson/demjson-2.0.ebuild,v 1.1 2014/05/03 07:48:21 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ http://pypi.python.org/pypi/demjson"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}