summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-10-06 15:53:48 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-10-06 15:53:48 +0000
commitfb921ae36a37dd1e5b5ad3ac7318b1c5450cdeb8 (patch)
tree86036c2a1227d8379943ba48d3dfa4a3111a85ac /dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-fb921ae36a37dd1e5b5ad3ac7318b1c5450cdeb8.tar.gz
gentoo-2-fb921ae36a37dd1e5b5ad3ac7318b1c5450cdeb8.tar.bz2
gentoo-2-fb921ae36a37dd1e5b5ad3ac7318b1c5450cdeb8.zip
Version bump of django-auth-ldap
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
new file mode 100644
index 000000000000..5abb968de85b
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/django-auth-ldap-1.2.2.ebuild,v 1.1 2014/10/06 15:53:48 ercpe Exp $
+
+EAPI=5
+# Although setup.py claims to support py3, python-ldap does not
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="http://pypi.python.org/pypi/django-auth-ldap http://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-2.0[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mockldap-0.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+#S="${WORKDIR}"/psagers-${PN}-80379ce59e6b
+
+PATCHES=( "${FILESDIR}"/docs.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" test/manage.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}