summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-17 13:37:03 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-17 13:37:03 +0000
commit0a52a5ab4ad9c5ec16764304a11eac0f3c6863f7 (patch)
treef3134583202544873b01f9475217f8b12162b772 /dev-python/django-pipeline/django-pipeline-1.2.24.ebuild
parentVersion bump. (diff)
downloadgentoo-2-0a52a5ab4ad9c5ec16764304a11eac0f3c6863f7.tar.gz
gentoo-2-0a52a5ab4ad9c5ec16764304a11eac0f3c6863f7.tar.bz2
gentoo-2-0a52a5ab4ad9c5ec16764304a11eac0f3c6863f7.zip
bumps, fixes Bug #469848
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-pipeline/django-pipeline-1.2.24.ebuild')
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.24.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.24.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.24.ebuild
new file mode 100644
index 000000000000..d385cfda6207
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.2.24.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.24.ebuild,v 1.1 2013/05/17 13:37:03 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/django-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+ rm -f docs/_build/doctrees/environment.pickle || die
+}
+
+python_compile() {
+ # Remove tests before reaching distutils-r1_src_install
+ rm -rf tests/ || die
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}