summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-03 15:07:01 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-03 15:07:01 +0000
commit9f8b38ede1902cd7ea23d1017a923db2f56d6fb2 (patch)
tree216cfd1091d122402c4bf1054ad0c0e999b88779 /dev-python/django-pipeline
parentDrop jruby. (diff)
downloadgentoo-2-9f8b38ede1902cd7ea23d1017a923db2f56d6fb2.tar.gz
gentoo-2-9f8b38ede1902cd7ea23d1017a923db2f56d6fb2.tar.bz2
gentoo-2-9f8b38ede1902cd7ea23d1017a923db2f56d6fb2.zip
add patch, acquired from master since last release, fixes test failures
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/ChangeLog6
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.26.ebuild4
-rw-r--r--dev-python/django-pipeline/files/1.3.26-tests.patch64
3 files changed, 72 insertions, 2 deletions
diff --git a/dev-python/django-pipeline/ChangeLog b/dev-python/django-pipeline/ChangeLog
index f8efc6d9bd6d..5c73e9b697eb 100644
--- a/dev-python/django-pipeline/ChangeLog
+++ b/dev-python/django-pipeline/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django-pipeline
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.27 2014/11/03 09:34:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.28 2014/11/03 15:07:01 idella4 Exp $
+
+ 03 Nov 2014; Ian Delaney <idella4@gentoo.org> +files/1.3.26-tests.patch,
+ django-pipeline-1.3.26.ebuild:
+ add patch, acquired from master since last release, fixes test failures
*django-pipeline-1.3.26 (03 Nov 2014)
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.26.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.26.ebuild
index 51008fecc214..934d27619e45 100644
--- a/dev-python/django-pipeline/django-pipeline-1.3.26.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.3.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.26.ebuild,v 1.1 2014/11/03 09:34:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.26.ebuild,v 1.2 2014/11/03 15:07:01 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -29,6 +29,8 @@ DEPEND="
test? ( ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}"/${PV}-tests.patch )
+
# As usual for test phase
DISTUTILS_IN_SOURCE_BUILD=1
diff --git a/dev-python/django-pipeline/files/1.3.26-tests.patch b/dev-python/django-pipeline/files/1.3.26-tests.patch
new file mode 100644
index 000000000000..5cdf5e760c96
--- /dev/null
+++ b/dev-python/django-pipeline/files/1.3.26-tests.patch
@@ -0,0 +1,64 @@
+https://github.com/cyberdelia/django-pipeline/commit/ba7b8d0d1cb621521a2025fed3e60786a010836d
+diff --git a/docs/configuration.rst b/docs/configuration.rst
+index 4385e23..e200bc3 100644
+--- a/docs/configuration.rst
++++ b/docs/configuration.rst
+@@ -185,7 +185,7 @@ Other settings
+ (
+ (b'text/coffeescript', '.coffee'),
+ (b'text/less', '.less'),
+- (b'application/javascript', '.js'),
++ (b'text/javascript', '.js'),
+ (b'text/x-sass', '.sass'),
+ (b'text/x-scss', '.scss')
+ )
+diff --git a/tests/tests/test_template.py b/tests/tests/test_template.py
+index 84b6957..a303d03 100644
+--- a/tests/tests/test_template.py
++++ b/tests/tests/test_template.py
+@@ -35,19 +35,19 @@ def test_package_css_disabled(self):
+
+ def test_package_js(self):
+ template = self.env.from_string(u"""{% compressed_js "scripts" %}""")
+- self.assertEqual(u'<script type="application/javascript" src="/static/scripts.js" charset="utf-8"></script>', template.render())
++ self.assertEqual(u'<script type="text/javascript" src="/static/scripts.js" charset="utf-8"></script>', template.render())
+
+ def test_package_js_async(self):
+ template = self.env.from_string(u"""{% compressed_js "scripts_async" %}""")
+- self.assertEqual(u'<script async type="application/javascript" src="/static/scripts_async.js" charset="utf-8"></script>', template.render())
++ self.assertEqual(u'<script async type="text/javascript" src="/static/scripts_async.js" charset="utf-8"></script>', template.render())
+
+ def test_package_js_defer(self):
+ template = self.env.from_string(u"""{% compressed_js "scripts_defer" %}""")
+- self.assertEqual(u'<script defer type="application/javascript" src="/static/scripts_defer.js" charset="utf-8"></script>', template.render())
++ self.assertEqual(u'<script defer type="text/javascript" src="/static/scripts_defer.js" charset="utf-8"></script>', template.render())
+
+ def test_package_js_async_defer(self):
+ template = self.env.from_string(u"""{% compressed_js "scripts_async_defer" %}""")
+- self.assertEqual(u'<script async defer type="application/javascript" src="/static/scripts_async_defer.js" charset="utf-8"></script>', template.render())
++ self.assertEqual(u'<script async defer type="text/javascript" src="/static/scripts_async_defer.js" charset="utf-8"></script>', template.render())
+
+
+ class DjangoTest(TestCase):
+@@ -64,16 +64,16 @@ def test_compressed_css(self):
+
+ def test_compressed_js(self):
+ rendered = self.render_template(u"""{% load compressed %}{% compressed_js "scripts" %}""")
+- self.assertEqual(u'<script type="application/javascript" src="/static/scripts.js" charset="utf-8"></script>', rendered)
++ self.assertEqual(u'<script type="text/javascript" src="/static/scripts.js" charset="utf-8"></script>', rendered)
+
+ def test_compressed_js_async(self):
+ rendered = self.render_template(u"""{% load compressed %}{% compressed_js "scripts_async" %}""")
+- self.assertEqual(u'<script async type="application/javascript" src="/static/scripts_async.js" charset="utf-8"></script>', rendered)
++ self.assertEqual(u'<script async type="text/javascript" src="/static/scripts_async.js" charset="utf-8"></script>', rendered)
+
+ def test_compressed_js_defer(self):
+ rendered = self.render_template(u"""{% load compressed %}{% compressed_js "scripts_defer" %}""")
+- self.assertEqual(u'<script defer type="application/javascript" src="/static/scripts_defer.js" charset="utf-8"></script>', rendered)
++ self.assertEqual(u'<script defer type="text/javascript" src="/static/scripts_defer.js" charset="utf-8"></script>', rendered)
+
+ def test_compressed_js_async_defer(self):
+ rendered = self.render_template(u"""{% load compressed %}{% compressed_js "scripts_async_defer" %}""")
+- self.assertEqual(u'<script async defer type="application/javascript" src="/static/scripts_async_defer.js" charset="utf-8"></script>', rendered)
++ self.assertEqual(u'<script async defer type="text/javascript" src="/static/scripts_async_defer.js" charset="utf-8"></script>', rendered)
+