summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-26 20:08:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-26 20:08:19 +0000
commit8094beefe52667b14bbb49038e4dfc341ce341ad (patch)
tree5bfe572f5c409e96f303eb22896e2db147680b0c /dev-python/django
parentold (diff)
downloadgentoo-2-8094beefe52667b14bbb49038e4dfc341ce341ad.tar.gz
gentoo-2-8094beefe52667b14bbb49038e4dfc341ce341ad.tar.bz2
gentoo-2-8094beefe52667b14bbb49038e4dfc341ce341ad.zip
Delete older ebuilds.
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.0.4.ebuild107
-rw-r--r--dev-python/django/django-1.1.2.ebuild107
-rw-r--r--dev-python/django/django-1.2.3.ebuild101
-rw-r--r--dev-python/django/django-1.2.4.ebuild96
-rw-r--r--dev-python/django/files/django-1.2.3-fix_tests.patch42
6 files changed, 6 insertions, 454 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 58247276efd5..394cf2c5ff4a 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.60 2011/01/26 19:56:35 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.61 2011/01/26 20:08:18 arfrever Exp $
+
+ 26 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -django-1.0.4.ebuild, -django-1.1.2.ebuild, -django-1.2.3.ebuild,
+ -files/django-1.2.3-fix_tests.patch, -django-1.2.4.ebuild:
+ Delete.
26 Jan 2011; Christian Faulhammer <fauli@gentoo.org>
django-1.2.4-r1.ebuild:
diff --git a/dev-python/django/django-1.0.4.ebuild b/dev-python/django/django-1.0.4.ebuild
deleted file mode 100644
index 421bfe04c263..000000000000
--- a/dev-python/django/django-1.0.4.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.4.ebuild,v 1.4 2010/09/22 19:57:31 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc examples mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( =dev-python/sphinx-0.6* )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/* AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- cat >> tests/settings.py << __EOF__
-DATABASE_ENGINE='sqlite3'
-DATABASE_NAME='test.db'
-ROOT_URLCONF='tests/urls.py'
-SITE_ID=1
-__EOF__
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=settings -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/*
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.1.2.ebuild b/dev-python/django/django-1.1.2.ebuild
deleted file mode 100644
index 7ea7cacef4fb..000000000000
--- a/dev-python/django/django-1.1.2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.1.2.ebuild,v 1.6 2010/09/22 19:57:31 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc examples mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( =dev-python/sphinx-0.6* )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/* AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- cat >> tests/settings.py << __EOF__
-DATABASE_ENGINE='sqlite3'
-DATABASE_NAME='test.db'
-ROOT_URLCONF='tests/urls.py'
-SITE_ID=1
-__EOF__
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=settings -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/*
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.2.3.ebuild b/dev-python/django/django-1.2.3.ebuild
deleted file mode 100644
index f10fd263910c..000000000000
--- a/dev-python/django/django-1.2.3.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.2.3.ebuild,v 1.4 2010/10/28 17:09:34 phajdan.jr Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils eutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/* AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-fix_tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.2.4.ebuild b/dev-python/django/django-1.2.4.ebuild
deleted file mode 100644
index 721f2a63f10e..000000000000
--- a/dev-python/django/django-1.2.4.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.2.4.ebuild,v 1.1 2010/12/23 14:46:35 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="dev-python/imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/* AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion extras/django_bash_completion
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- bash-completion_pkg_postinst
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/files/django-1.2.3-fix_tests.patch b/dev-python/django/files/django-1.2.3-fix_tests.patch
deleted file mode 100644
index c217c93ad9f5..000000000000
--- a/dev-python/django/files/django-1.2.3-fix_tests.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-http://code.djangoproject.com/changeset/13750
-http://code.djangoproject.com/changeset/13764
-
---- tests/regressiontests/admin_views/tests.py
-+++ tests/regressiontests/admin_views/tests.py
-@@ -2206,16 +2206,19 @@
- self.assertContains(response, "<h2>Built-in tags</h2>", count=2)
-
- # A builtin tag exists in both the index and detail
-- self.assertContains(response, '<h3 id="autoescape">autoescape</h3>')
-- self.assertContains(response, '<li><a href="#autoescape">autoescape</a></li>')
-+ self.assertContains(response, '<h3 id="built_in-autoescape">autoescape</h3>')
-+ self.assertContains(response, '<li><a href="#built_in-autoescape">autoescape</a></li>')
-
- # An app tag exists in both the index and detail
-- # The builtin tag group exists
-+ self.assertContains(response, '<h3 id="comments-get_comment_count">get_comment_count</h3>')
-+ self.assertContains(response, '<li><a href="#comments-get_comment_count">get_comment_count</a></li>')
-+
-+ # The admin list tag group exists
- self.assertContains(response, "<h2>admin_list</h2>", count=2)
-
-- # A builtin tag exists in both the index and detail
-- self.assertContains(response, '<h3 id="autoescape">autoescape</h3>')
-- self.assertContains(response, '<li><a href="#admin_actions">admin_actions</a></li>')
-+ # An admin list tag exists in both the index and detail
-+ self.assertContains(response, '<h3 id="admin_list-admin_actions">admin_actions</h3>')
-+ self.assertContains(response, '<li><a href="#admin_list-admin_actions">admin_actions</a></li>')
-
- def test_filters(self):
- response = self.client.get('/test_admin/admin/doc/filters/')
-@@ -2224,8 +2227,8 @@
- self.assertContains(response, "<h2>Built-in filters</h2>", count=2)
-
- # A builtin filter exists in both the index and detail
-- self.assertContains(response, '<h3 id="add">add</h3>')
-- self.assertContains(response, '<li><a href="#add">add</a></li>')
-+ self.assertContains(response, '<h3 id="built_in-add">add</h3>')
-+ self.assertContains(response, '<li><a href="#built_in-add">add</a></li>')
-
- except ImportError:
- pass