summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-02 04:22:26 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-02 04:22:26 +0000
commit89ecaf71568c75b8a1c456f1230b57065c14063d (patch)
tree700a34878357e8b26ae64d4baeddd81630fcb24a /dev-python/django
parentversion bump (diff)
downloadgentoo-2-89ecaf71568c75b8a1c456f1230b57065c14063d.tar.gz
gentoo-2-89ecaf71568c75b8a1c456f1230b57065c14063d.tar.bz2
gentoo-2-89ecaf71568c75b8a1c456f1230b57065c14063d.zip
Cleanup webapp.eclass usage.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog6
-rw-r--r--dev-python/django/django-1.5.1.ebuild17
-rw-r--r--dev-python/django/django-9999.ebuild17
3 files changed, 17 insertions, 23 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index dc7ae2fa0e0c..10cd3c2cb5dd 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.109 2013/06/01 19:35:37 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.110 2013/06/02 04:22:26 floppym Exp $
+
+ 02 Jun 2013; Mike Gilbert <floppym@gentoo.org> django-1.5.1.ebuild,
+ django-9999.ebuild:
+ Cleanup webapp.eclass usage.
01 Jun 2013; Mike Gilbert <floppym@gentoo.org> django-1.5.1.ebuild,
django-9999.ebuild:
diff --git a/dev-python/django/django-1.5.1.ebuild b/dev-python/django/django-1.5.1.ebuild
index e4b26c604540..485609e048d2 100644
--- a/dev-python/django/django-1.5.1.ebuild
+++ b/dev-python/django/django-1.5.1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.5.1.ebuild,v 1.3 2013/06/01 19:35:37 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.5.1.ebuild,v 1.4 2013/06/02 04:22:26 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
PYTHON_REQ_USE='sqlite?'
+WEBAPP_NO_AUTO_INSTALL="yes"
inherit bash-completion-r1 distutils-r1 versionator webapp
@@ -74,14 +75,8 @@ python_install_all() {
}
pkg_postinst() {
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- elog
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
-
- # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
+ elog "A copy of the admin media is available to webapp-config for installation in a"
+ elog "webroot, as well as the traditional location in python's site-packages dir"
+ elog "for easy development."
+ webapp_pkg_postinst
}
diff --git a/dev-python/django/django-9999.ebuild b/dev-python/django/django-9999.ebuild
index e9db0a09b028..035426e524fa 100644
--- a/dev-python/django/django-9999.ebuild
+++ b/dev-python/django/django-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.21 2013/06/01 19:35:37 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.22 2013/06/02 04:22:26 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
PYTHON_REQ_USE='sqlite?'
+WEBAPP_NO_AUTO_INSTALL="yes"
#if LIVE
inherit git-2
@@ -79,14 +80,8 @@ python_install_all() {
}
pkg_postinst() {
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- elog
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
-
- # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
+ elog "A copy of the admin media is available to webapp-config for installation in a"
+ elog "webroot, as well as the traditional location in python's site-packages dir"
+ elog "for easy development."
+ webapp_pkg_postinst
}