summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-05-02 00:55:23 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-05-02 00:55:23 +0000
commit5f4168b22b85c02dea74191039e5ad93c025ef86 (patch)
tree48debe55c695c8cfe1eb9cd95889eafe91c53912 /dev-python/dnspython/dnspython-1.3.0.ebuild
parentBacked out patches. (Manifest recommit) (diff)
downloadgentoo-2-5f4168b22b85c02dea74191039e5ad93c025ef86.tar.gz
gentoo-2-5f4168b22b85c02dea74191039e5ad93c025ef86.tar.bz2
gentoo-2-5f4168b22b85c02dea74191039e5ad93c025ef86.zip
Initial import, bug #46500.
Diffstat (limited to 'dev-python/dnspython/dnspython-1.3.0.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.3.0.ebuild b/dev-python/dnspython/dnspython-1.3.0.ebuild
new file mode 100644
index 000000000000..7cd75de81c01
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/dnspython-1.3.0.ebuild,v 1.1 2004/05/02 00:55:23 kloeri Exp $
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python."
+HOMEPAGE="http://www.dnspython.org/"
+SRC_URI="http://www.dnspython.org/kits/stable/${P}.tar.gz"
+LICENSE="as-is"
+DEPEND=">=virtual/python-2.2
+ sys-devel/make"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+src_install() {
+ distutils_src_install
+ dodoc TODO
+ dodir /usr/share/doc/${P}
+ cp -r examples ${D}/usr/share/doc/${P}
+ dodir /usr/share/${PN}
+ cp -r tests ${D}/usr/share/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is sparse at the moment. Use pydoc,"
+ einfo "or read the HTML documentation at the dnspython home page"
+ einfo
+ einfo "You can test your dnspython installation running:"
+ einfo "# cd /usr/share/${PN}/tests && make"
+ einfo
+}