summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 16:55:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 16:55:07 +0000
commit072bbf7b73362c341e4a1316efe55b13aa8e913d (patch)
tree7875bc558f39aad88122c38292b3f135b5cd0458 /dev-python/dulwich
parentalpha/ia64/s390/sh/sparc stable wrt #344827 (diff)
downloadgentoo-2-072bbf7b73362c341e4a1316efe55b13aa8e913d.tar.gz
gentoo-2-072bbf7b73362c341e4a1316efe55b13aa8e913d.tar.bz2
gentoo-2-072bbf7b73362c341e4a1316efe55b13aa8e913d.zip
Avoid failure of dulwich.tests.test_diff_tree.TreeChangesTest.test_merge_entries() in a different way.
(Portage version: 2.2.0_alpha23_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/dulwich-0.7.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/dulwich/dulwich-0.7.0.ebuild b/dev-python/dulwich/dulwich-0.7.0.ebuild
index cafa5b050001..da914a0b589d 100644
--- a/dev-python/dulwich/dulwich-0.7.0.ebuild
+++ b/dev-python/dulwich/dulwich-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.7.0.ebuild,v 1.1 2011/02/12 00:33:22 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.7.0.ebuild,v 1.2 2011/02/12 16:55:07 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -25,11 +25,19 @@ RDEPEND=""
src_prepare() {
distutils_src_prepare
+ # https://github.com/jelmer/dulwich/commit/ee087a68c995bda4e83c464bf9339523f04e7a23
sed -e "s/from dulwich.utils import/from dulwich.tests.compat.utils import/" -i dulwich/tests/compat/test_web.py
- sed -e "/test_merge_entries =/,+1d" -i dulwich/tests/test_diff_tree.py
+
sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
}
+distutils_src_test_pre_hook() {
+ local module
+ for module in _diff_tree _objects _pack; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}
+
src_install() {
distutils_src_install