summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-03 17:15:23 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-03 17:15:23 +0000
commit7f6190a79146f0a2367b49f8280ec7d0e93b3f75 (patch)
tree7e2b73cdaf0b3e965b950df5e102663a975aa2dd /dev-python/editobj
parentMigrate to EAPI 5. Add missing dependencies. Fix .desktop validation. Improve... (diff)
downloadgentoo-2-7f6190a79146f0a2367b49f8280ec7d0e93b3f75.tar.gz
gentoo-2-7f6190a79146f0a2367b49f8280ec7d0e93b3f75.tar.bz2
gentoo-2-7f6190a79146f0a2367b49f8280ec7d0e93b3f75.zip
revbump, migrate -> distutils-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/editobj')
-rw-r--r--dev-python/editobj/ChangeLog7
-rw-r--r--dev-python/editobj/editobj-0.5.7-r2.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/editobj/ChangeLog b/dev-python/editobj/ChangeLog
index 01204ae67c7e..525754b0a76e 100644
--- a/dev-python/editobj/ChangeLog
+++ b/dev-python/editobj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/editobj
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/editobj/ChangeLog,v 1.24 2013/02/21 13:29:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/editobj/ChangeLog,v 1.25 2013/06/03 17:15:23 idella4 Exp $
+
+*editobj-0.5.7-r2 (03 Jun 2013)
+
+ 03 Jun 2013; Ian Delaney <idella4@gentoo.org> +editobj-0.5.7-r2.ebuild:
+ revbump, migrate -> distutils-r1
21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> editobj-0.5.7-r1.ebuild:
Stable for ia64, wrt bug #457188
diff --git a/dev-python/editobj/editobj-0.5.7-r2.ebuild b/dev-python/editobj/editobj-0.5.7-r2.ebuild
new file mode 100644
index 000000000000..511b4627511d
--- /dev/null
+++ b/dev-python/editobj/editobj-0.5.7-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/editobj/editobj-0.5.7-r2.ebuild,v 1.1 2013/06/03 17:15:23 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/editobj/EditObj}"
+
+DESCRIPTION="EditObj can create a dialog box to edit ANY Python object."
+SRC_URI="http://download.gna.org/songwrite/${MY_P}.tar.gz"
+HOMEPAGE="http://home.gna.org/oomadness/en/editobj/index.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+IUSE="+examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}