summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-28 03:48:16 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-28 03:48:16 +0000
commit71a7817687c80c888692ae9d27f0d3addbfb44f7 (patch)
treef624bd64c9713c43d30c81d3874c89d4ff878b3a /dev-python/epsilon
parentfixed bad manifest on lammps-20140129 (diff)
downloadgentoo-2-71a7817687c80c888692ae9d27f0d3addbfb44f7.tar.gz
gentoo-2-71a7817687c80c888692ae9d27f0d3addbfb44f7.tar.bz2
gentoo-2-71a7817687c80c888692ae9d27f0d3addbfb44f7.zip
bump; drop py2.6 (fails some tests), update deps, add IUSE test + testrunner dep + test phase
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/epsilon')
-rw-r--r--dev-python/epsilon/ChangeLog10
-rw-r--r--dev-python/epsilon/epsilon-0.7.0.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-python/epsilon/ChangeLog b/dev-python/epsilon/ChangeLog
index dd3eece8997f..c01999711b79 100644
--- a/dev-python/epsilon/ChangeLog
+++ b/dev-python/epsilon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/epsilon
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.30 2013/08/09 15:42:55 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.31 2014/01/28 03:48:16 idella4 Exp $
+
+*epsilon-0.7.0 (28 Jan 2014)
+
+ 28 Jan 2014; Ian Delaney <idella4@gentoo.org> +epsilon-0.7.0.ebuild:
+ bump; drop py2.6 (fails some tests), update deps, add IUSE test + testrunner
+ dep + test phase
*epsilon-0.6.0-r2 (09 Aug 2013)
diff --git a/dev-python/epsilon/epsilon-0.7.0.ebuild b/dev-python/epsilon/epsilon-0.7.0.ebuild
new file mode 100644
index 000000000000..cff17f109b81
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.7.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.7.0.ebuild,v 1.1 2014/01/28 03:48:16 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1 eutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon http://pypi.python.org/pypi/Epsilon"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ ${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+#Lets run some tests, having prepped them
+python_test() {
+ # No testrunner seems stipulated within the source; pytest and nosetests both work
+ nosetests ${PN}/test || die "testsuite failed under ${EPYTHON}"
+}