summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2009-02-11 09:58:11 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2009-02-11 09:58:11 +0000
commit827fb9713f4c74b5c9fb33ce34fb8e6d846e0dbc (patch)
treef05c932d50a66663fd40594c9d59566b71caa7d6 /dev-python/epsilon
parentVersion bump. (diff)
downloadgentoo-2-827fb9713f4c74b5c9fb33ce34fb8e6d846e0dbc.tar.gz
gentoo-2-827fb9713f4c74b5c9fb33ce34fb8e6d846e0dbc.tar.bz2
gentoo-2-827fb9713f4c74b5c9fb33ce34fb8e6d846e0dbc.zip
apply patch to correct version now. also update plugin cache
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/epsilon')
-rw-r--r--dev-python/epsilon/ChangeLog7
-rw-r--r--dev-python/epsilon/epsilon-0.5.11.ebuild15
-rw-r--r--dev-python/epsilon/epsilon-0.5.9.ebuild5
3 files changed, 20 insertions, 7 deletions
diff --git a/dev-python/epsilon/ChangeLog b/dev-python/epsilon/ChangeLog
index 8bbc526290b8..a0a4ae46b7de 100644
--- a/dev-python/epsilon/ChangeLog
+++ b/dev-python/epsilon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/epsilon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.13 2009/02/11 08:28:49 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/ChangeLog,v 1.14 2009/02/11 09:58:11 lordvan Exp $
+
+ 11 Feb 2009; Thomas Raschbacher <lordvan@gentoo.org> epsilon-0.5.9.ebuild,
+ epsilon-0.5.11.ebuild:
+ apply patch to 0.5.11 instead of 0.5.9 and update twisted plugin cache
+ afterwards
11 Feb 2009; Thomas Raschbacher <lordvan@gentoo.org> ChangeLog:
patch so plugin cache update can be disabled with env var for ebuilds
diff --git a/dev-python/epsilon/epsilon-0.5.11.ebuild b/dev-python/epsilon/epsilon-0.5.11.ebuild
index 0295081d9b40..fc10603c46cf 100644
--- a/dev-python/epsilon/epsilon-0.5.11.ebuild
+++ b/dev-python/epsilon/epsilon-0.5.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.5.11.ebuild,v 1.2 2009/02/10 09:55:46 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.5.11.ebuild,v 1.3 2009/02/11 09:58:11 lordvan Exp $
-inherit distutils
+inherit twisted distutils
DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class."
HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon"
@@ -32,6 +32,9 @@ src_unpack() {
sed -i \
-e "s#bin/benchmark#bin/epsilon-benchmark#" \
setup.py || die "sed failed"
+ # otherwise we get sandbox violations as it wants to update
+ # the plugin cache
+ epatch "${FILESDIR}/epsilon_plugincache_portagesandbox.patch"
}
src_compile() {
@@ -44,3 +47,11 @@ src_test() {
rm epsilon/test/test_release.py*
PYTHONPATH=. trial epsilon || die "tests failed"
}
+
+pkg_postrm() {
+ twisted_pkg_postrm
+}
+
+pkg_postinst() {
+ twisted_pkg_postinst
+}
diff --git a/dev-python/epsilon/epsilon-0.5.9.ebuild b/dev-python/epsilon/epsilon-0.5.9.ebuild
index 4c243af79f56..2fdc0b7e095f 100644
--- a/dev-python/epsilon/epsilon-0.5.9.ebuild
+++ b/dev-python/epsilon/epsilon-0.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.5.9.ebuild,v 1.2 2009/02/11 08:28:49 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epsilon/epsilon-0.5.9.ebuild,v 1.3 2009/02/11 09:58:11 lordvan Exp $
inherit distutils
@@ -30,9 +30,6 @@ src_unpack() {
sed -i \
-e "s#bin/benchmark#bin/epsilon-benchmark#" \
setup.py || die "sed failed"
- # otherwise we get sandbox violations as it wants to update
- # the plugin cache
- epatch "${FILESDIR}/epsilon_plugincache_portagesandbox.patch"
}
src_compile() {