summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-31 18:09:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-31 18:09:13 +0000
commit49b9f780617da886965068ea16cfb06a06e64956 (patch)
tree725bcf27df1cff854baa7f2e21186cd82dea7620 /dev-python/execnet/execnet-1.0.8.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-49b9f780617da886965068ea16cfb06a06e64956.tar.gz
gentoo-2-49b9f780617da886965068ea16cfb06a06e64956.tar.bz2
gentoo-2-49b9f780617da886965068ea16cfb06a06e64956.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/execnet/execnet-1.0.8.ebuild')
-rw-r--r--dev-python/execnet/execnet-1.0.8.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/execnet/execnet-1.0.8.ebuild b/dev-python/execnet/execnet-1.0.8.ebuild
new file mode 100644
index 000000000000..46d7db47d9f1
--- /dev/null
+++ b/dev-python/execnet/execnet-1.0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/execnet/execnet-1.0.8.ebuild,v 1.1 2010/07/31 18:09:13 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils eutils
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ http://pypi.python.org/pypi/execnet/"
+SRC_URI="http://pypi.python.org/packages/source/e/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Fix test with nice (bug #301417).
+ epatch "${FILESDIR}/${PN}-1.0.6-test-nice.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd doc
+ emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ distutils_src_test testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/_build/html/* || die "dohtml failed"
+ fi
+}