summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-06-21 20:22:51 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-06-21 20:22:51 +0000
commitf5633c4d6df04ce6061d767dd5548a1d164a53a4 (patch)
tree5aef667d5863a065158bccc8031386920fd3fcea /dev-python/execnet
parentRemove old. (diff)
downloadgentoo-2-f5633c4d6df04ce6061d767dd5548a1d164a53a4.tar.gz
gentoo-2-f5633c4d6df04ce6061d767dd5548a1d164a53a4.tar.bz2
gentoo-2-f5633c4d6df04ce6061d767dd5548a1d164a53a4.zip
Version bump
(Portage version: 2.2.0_alpha110/cvs/Linux i686)
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/ChangeLog9
-rw-r--r--dev-python/execnet/execnet-1.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/execnet/ChangeLog b/dev-python/execnet/ChangeLog
index 25956eda1685..c481e1966aed 100644
--- a/dev-python/execnet/ChangeLog
+++ b/dev-python/execnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/execnet
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/execnet/ChangeLog,v 1.12 2011/08/05 22:48:09 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/execnet/ChangeLog,v 1.13 2012/06/21 20:22:51 grozin Exp $
+
+*execnet-1.1 (21 Jun 2012)
+
+ 21 Jun 2012; Andrey Grozin <grozin@gentoo.org> +execnet-1.1.ebuild:
+ Version bump
05 Aug 2011; Markos Chandras <hwoarang@gentoo.org>
-files/execnet-1.0.6-test-nice.patch, -execnet-1.0.8.ebuild:
diff --git a/dev-python/execnet/execnet-1.1.ebuild b/dev-python/execnet/execnet-1.1.ebuild
new file mode 100644
index 000000000000..03606f81fc89
--- /dev/null
+++ b/dev-python/execnet/execnet-1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/execnet/execnet-1.1.ebuild,v 1.1 2012/06/21 20:22:51 grozin Exp $
+
+EAPI=4
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ http://pypi.python.org/pypi/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd doc
+ emake html
+ fi
+}
+
+src_test() {
+ distutils_src_test testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/_build/html/*
+ fi
+}