summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-08 14:47:17 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-08 14:47:17 +0000
commitfc30c6f6a49c3307775b1167a4b5aee889f00e92 (patch)
treef20eb5db135ef0466a56ad8e2a4b5e00de460f05 /dev-python/fabric/fabric-1.6.1-r1.ebuild
parentVersion bump, convert to EAPI5 (diff)
downloadgentoo-2-fc30c6f6a49c3307775b1167a4b5aee889f00e92.tar.gz
gentoo-2-fc30c6f6a49c3307775b1167a4b5aee889f00e92.tar.bz2
gentoo-2-fc30c6f6a49c3307775b1167a4b5aee889f00e92.zip
revbump -> distutils-r1, deps upgraded, removed 1.6.1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/fabric/fabric-1.6.1-r1.ebuild')
-rw-r--r--dev-python/fabric/fabric-1.6.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/fabric/fabric-1.6.1-r1.ebuild b/dev-python/fabric/fabric-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..d17e91a1050d
--- /dev/null
+++ b/dev-python/fabric/fabric-1.6.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.6.1-r1.ebuild,v 1.1 2013/06/08 14:47:17 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple pythonic tool for remote execution and deployment."
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/paramiko-1.10.0[${PYTHON_USEDEP}]
+ python_targets_python2_5? ( dev-python/multiprocessing[python_targets_python2_5] )
+ python_targets_python2_6? ( dev-python/multiprocessing[python_targets_python2_6] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( <dev-python/fudge-1.0 )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}