summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 08:11:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 08:11:53 +0000
commit4eb0b9a1c289a088e9fbac5aaa3575b06d5ffb01 (patch)
tree665ecce34476550241430187343be58c73819125 /dev-python/fixtures
parentStraighten out py34 keywording a bit (diff)
downloadgentoo-2-4eb0b9a1c289a088e9fbac5aaa3575b06d5ffb01.tar.gz
gentoo-2-4eb0b9a1c289a088e9fbac5aaa3575b06d5ffb01.tar.bz2
gentoo-2-4eb0b9a1c289a088e9fbac5aaa3575b06d5ffb01.zip
Straighten out py34 keywording
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/ChangeLog8
-rw-r--r--dev-python/fixtures/fixtures-0.3.14-r1.ebuild4
-rw-r--r--dev-python/fixtures/fixtures-0.3.14-r2.ebuild31
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-python/fixtures/ChangeLog b/dev-python/fixtures/ChangeLog
index d0d43d3768e7..240c58334536 100644
--- a/dev-python/fixtures/ChangeLog
+++ b/dev-python/fixtures/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fixtures
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.13 2014/06/12 07:47:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.14 2014/06/12 08:11:53 patrick Exp $
+
+*fixtures-0.3.14-r2 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org> +fixtures-0.3.14-r2.ebuild,
+ fixtures-0.3.14-r1.ebuild:
+ Straighten out py34 keywording
12 Jun 2014; Patrick Lauer <patrick@gentoo.org> fixtures-0.3.14-r1.ebuild:
Add py34 support
diff --git a/dev-python/fixtures/fixtures-0.3.14-r1.ebuild b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
index ac753eb650ae..97f1a277159b 100644
--- a/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
+++ b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14-r1.ebuild,v 1.7 2014/06/12 07:47:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14-r1.ebuild,v 1.8 2014/06/12 08:11:53 patrick Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy pypy2_0 )
inherit distutils-r1
diff --git a/dev-python/fixtures/fixtures-0.3.14-r2.ebuild b/dev-python/fixtures/fixtures-0.3.14-r2.ebuild
new file mode 100644
index 000000000000..e866f0254424
--- /dev/null
+++ b/dev-python/fixtures/fixtures-0.3.14-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14-r2.ebuild,v 1.1 2014/06/12 08:11:53 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more."
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/testtools-0.9.22"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/ > /dev/null
+ ln -sf ../README .
+ nosetests lib/${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+}