summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-26 00:43:09 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-26 00:43:09 +0000
commit7ce21358e00c7da0de3390bb6efc574b878bfd8a (patch)
tree5fbdd3fc80dde94c4d140e467dc53cd4e605fe89 /dev-python/fixtures
parentinitial add of oslo.config (as oslo-config) (diff)
downloadgentoo-2-7ce21358e00c7da0de3390bb6efc574b878bfd8a.tar.gz
gentoo-2-7ce21358e00c7da0de3390bb6efc574b878bfd8a.tar.bz2
gentoo-2-7ce21358e00c7da0de3390bb6efc574b878bfd8a.zip
new fixtures for new oslo-config
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/ChangeLog8
-rw-r--r--dev-python/fixtures/fixtures-0.3.14.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/fixtures/ChangeLog b/dev-python/fixtures/ChangeLog
index aa0659ec421f..cf8166c599a8 100644
--- a/dev-python/fixtures/ChangeLog
+++ b/dev-python/fixtures/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fixtures
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.5 2013/09/05 18:46:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.6 2013/09/26 00:43:09 prometheanfire Exp $
+
+*fixtures-0.3.14 (26 Sep 2013)
+
+ 26 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +fixtures-0.3.14.ebuild:
+ new fixtures for new oslo-config
05 Sep 2013; Michał Górny <mgorny@gentoo.org> fixtures-0.3.12-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/fixtures/fixtures-0.3.14.ebuild b/dev-python/fixtures/fixtures-0.3.14.ebuild
new file mode 100644
index 000000000000..17ea386aad3e
--- /dev/null
+++ b/dev-python/fixtures/fixtures-0.3.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14.ebuild,v 1.1 2013/09/26 00:43:09 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more."
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/testtools-0.9.22"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/ > /dev/null
+ ln -sf ../README .
+ nosetests lib/${PN}/tests/{test_callmany.py,test_fixture.py,test_testcase.py} \
+ || die "Tests failed under ${EPYTHON}"
+}