summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-07-09 15:46:18 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-07-09 15:46:18 +0000
commit8aceba882e7d50169c370f56b0550bfdafe12935 (patch)
tree24dae0416f25e6f75e3d6959f1ec124980e44ce1 /dev-python/fixtures
parentRemove mirror restriction. Remove old. (diff)
downloadgentoo-2-8aceba882e7d50169c370f56b0550bfdafe12935.tar.gz
gentoo-2-8aceba882e7d50169c370f56b0550bfdafe12935.tar.bz2
gentoo-2-8aceba882e7d50169c370f56b0550bfdafe12935.zip
removed a erronious dep, fixed the desc and homepage and removed a tab at the end
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/ChangeLog9
-rw-r--r--dev-python/fixtures/fixtures-0.3.12-r1.ebuild (renamed from dev-python/fixtures/fixtures-0.3.12.ebuild)13
2 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/fixtures/ChangeLog b/dev-python/fixtures/ChangeLog
index 87a5f629e301..ea8382b4961a 100644
--- a/dev-python/fixtures/ChangeLog
+++ b/dev-python/fixtures/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/fixtures
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.2 2013/06/08 15:52:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.3 2013/07/09 15:46:18 prometheanfire Exp $
+
+*fixtures-0.3.12-r1 (09 Jul 2013)
+
+ 09 Jul 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +fixtures-0.3.12-r1.ebuild, -fixtures-0.3.12.ebuild:
+ removed a erronious dep, fixed the desc and homepage and removed a tab at the
+ end
08 Jun 2013; Ian Delaney <idella4@gentoo.org> fixtures-0.3.12.ebuild:
add py3.3 support, test phase and nose for tests providing coverage output
diff --git a/dev-python/fixtures/fixtures-0.3.12.ebuild b/dev-python/fixtures/fixtures-0.3.12-r1.ebuild
index 28bb64c1677c..c229b5181fec 100644
--- a/dev-python/fixtures/fixtures-0.3.12.ebuild
+++ b/dev-python/fixtures/fixtures-0.3.12-r1.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.12.ebuild,v 1.2 2013/06/08 15:52:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.12-r1.ebuild,v 1.1 2013/07/09 15:46:18 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 python{3_2,3_3} )
inherit distutils-r1
-DESCRIPTION="A client for the OpenStack Glance API"
-HOMEPAGE="https://launchpad.net/python-cinderclient"
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more."
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="Apache-2.0"
+LICENSE="|| ( Apache-2.0 BSD )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
# nose not listed but provides coverage output of tests
# run of test files by python lacks any output except on fail
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/testtools-0.9.22"
DISTUTILS_IN_SOURCE_BUILD=1
@@ -28,4 +27,4 @@ python_test() {
ln -sf ../README .
nosetests lib/${PN}/tests/{test_callmany.py,test_fixture.py,test_testcase.py} \
|| die "Tests failed under ${EPYTHON}"
-}
+}