summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-08 15:52:42 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-08 15:52:42 +0000
commitbf665d3aad2af2a255df46f3e72c1ca62661aab1 (patch)
tree2f2255d8879d28950635dffeedf204775a7ca864 /dev-python/fixtures
parentUpdate to EAPI5 (diff)
downloadgentoo-2-bf665d3aad2af2a255df46f3e72c1ca62661aab1.tar.gz
gentoo-2-bf665d3aad2af2a255df46f3e72c1ca62661aab1.tar.bz2
gentoo-2-bf665d3aad2af2a255df46f3e72c1ca62661aab1.zip
add py3.3 support, test phase and nose for tests providing coverage output
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/ChangeLog6
-rw-r--r--dev-python/fixtures/fixtures-0.3.12.ebuild19
2 files changed, 19 insertions, 6 deletions
diff --git a/dev-python/fixtures/ChangeLog b/dev-python/fixtures/ChangeLog
index e2200360242a..87a5f629e301 100644
--- a/dev-python/fixtures/ChangeLog
+++ b/dev-python/fixtures/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for dev-python/fixtures
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.1 2013/01/21 08:30:51 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/ChangeLog,v 1.2 2013/06/08 15:52:42 idella4 Exp $
+
+ 08 Jun 2013; Ian Delaney <idella4@gentoo.org> fixtures-0.3.12.ebuild:
+ add py3.3 support, test phase and nose for tests providing coverage output
*fixtures-0.3.12 (21 Jan 2013)
21 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
+fixtures-0.3.12.ebuild, +metadata.xml:
adding fixtures for python-cinderclient
-
diff --git a/dev-python/fixtures/fixtures-0.3.12.ebuild b/dev-python/fixtures/fixtures-0.3.12.ebuild
index 2856811e4eae..28bb64c1677c 100644
--- a/dev-python/fixtures/fixtures-0.3.12.ebuild
+++ b/dev-python/fixtures/fixtures-0.3.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.12.ebuild,v 1.1 2013/01/21 08:30:51 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.12.ebuild,v 1.2 2013/06/08 15:52:42 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_2 )
+PYTHON_COMPAT=( python2_7 python{3_2,3_3} )
inherit distutils-r1
@@ -14,7 +14,18 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/testtools-0.9.22"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/ > /dev/null
+ ln -sf ../README .
+ nosetests lib/${PN}/tests/{test_callmany.py,test_fixture.py,test_testcase.py} \
+ || die "Tests failed under ${EPYTHON}"
+}