summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-15 01:35:57 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-15 01:35:57 +0000
commit493aaacc9b2964f44bc8c7e775a94ab98c521897 (patch)
tree82266337e216a0d925971200a991d44f250f2f98 /dev-python/flask-mongoengine
parentDrop old. (diff)
downloadgentoo-2-493aaacc9b2964f44bc8c7e775a94ab98c521897.tar.gz
gentoo-2-493aaacc9b2964f44bc8c7e775a94ab98c521897.tar.bz2
gentoo-2-493aaacc9b2964f44bc8c7e775a94ab98c521897.zip
bump update deps
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-mongoengine')
-rw-r--r--dev-python/flask-mongoengine/ChangeLog7
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/flask-mongoengine/ChangeLog b/dev-python/flask-mongoengine/ChangeLog
index 9a84ec77c4b0..0fdc7cef6c3c 100644
--- a/dev-python/flask-mongoengine/ChangeLog
+++ b/dev-python/flask-mongoengine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-mongoengine
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-mongoengine/ChangeLog,v 1.4 2015/06/03 18:39:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-mongoengine/ChangeLog,v 1.5 2015/06/15 01:35:57 idella4 Exp $
+
+*flask-mongoengine-0.7.1 (15 Jun 2015)
+
+ 15 Jun 2015; Ian Delaney <idella4@gentoo.org> +flask-mongoengine-0.7.1.ebuild:
+ bump update deps
03 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild
new file mode 100644
index 000000000000..0c840c541dfb
--- /dev/null
+++ b/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild,v 1.1 2015/06/15 01:35:57 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask support for MongoDB and with WTF model forms"
+HOMEPAGE="https://pypi.python.org/pypi/flask-mongoengine/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}