summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-03 05:44:13 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-03 05:44:13 +0000
commit7e03824e73d132d1f8a69f6526e480ef4dbbf4f6 (patch)
treed6018dd8a5cbc61ce9f750451d17c8d0017c7158 /dev-python/formencode
parent[R]DEPEND on setuptools, thanks Arfrever. (diff)
downloadgentoo-2-7e03824e73d132d1f8a69f6526e480ef4dbbf4f6.tar.gz
gentoo-2-7e03824e73d132d1f8a69f6526e480ef4dbbf4f6.tar.bz2
gentoo-2-7e03824e73d132d1f8a69f6526e480ef4dbbf4f6.zip
revbump; migrate -> distutils-r1, deps of testsuite added but disabled, tests set to restrict, depnds on Bug #473154
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/formencode')
-rw-r--r--dev-python/formencode/ChangeLog8
-rw-r--r--dev-python/formencode/formencode-1.2.6-r1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/formencode/ChangeLog b/dev-python/formencode/ChangeLog
index 3ee3a9a02f8b..cc40c1345f51 100644
--- a/dev-python/formencode/ChangeLog
+++ b/dev-python/formencode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/formencode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/ChangeLog,v 1.28 2013/01/11 07:23:38 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/ChangeLog,v 1.29 2013/07/03 05:44:13 idella4 Exp $
+
+*formencode-1.2.6-r1 (03 Jul 2013)
+
+ 03 Jul 2013; Ian Delaney <idella4@gentoo.org> +formencode-1.2.6-r1.ebuild:
+ revbump; migrate -> distutils-r1, deps of testsuite added but disabled, tests
+ set to restrict, depnds on Bug #473154
*formencode-1.2.6 (11 Jan 2013)
diff --git a/dev-python/formencode/formencode-1.2.6-r1.ebuild b/dev-python/formencode/formencode-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..a82aed098a9c
--- /dev/null
+++ b/dev-python/formencode/formencode-1.2.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/formencode-1.2.6-r1.ebuild,v 1.1 2013/07/03 05:44:13 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation, and conversion package"
+HOMEPAGE="http://formencode.org/ http://pypi.python.org/pypi/FormEncode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+ # https://bugs.gentoo.org/show_bug.cgi?id=473154
+# test? ( dev-python/nose[${PYTHON_USEDEP}]
+# dev-python/pycountry[${PYTHON_USEDEP}]
+# dev-python/pydns[${PYTHON_USEDEP}] )"
+RDEPEND=""
+RESTRICT="test"
+DOCS=( docs/{index.txt,modules.txt} )
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}