summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-27 17:05:50 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-27 17:05:50 +0000
commit2b1cd3bd7f6583fee1f8af69c5c92aeb82300523 (patch)
treeeaf5d521cf0dec99920136d1b28b17b40db3bb73 /dev-python/gnome-python-desktop
parentgnome 2.18.0 (diff)
downloadgentoo-2-2b1cd3bd7f6583fee1f8af69c5c92aeb82300523.tar.gz
gentoo-2-2b1cd3bd7f6583fee1f8af69c5c92aeb82300523.tar.bz2
gentoo-2-2b1cd3bd7f6583fee1f8af69c5c92aeb82300523.zip
gnome 2.18.0
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-python/gnome-python-desktop')
-rw-r--r--dev-python/gnome-python-desktop/ChangeLog8
-rw-r--r--dev-python/gnome-python-desktop/files/digest-gnome-python-desktop-2.18.03
-rw-r--r--dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild61
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/gnome-python-desktop/ChangeLog b/dev-python/gnome-python-desktop/ChangeLog
index d14e01811a97..b23a37d1b66d 100644
--- a/dev-python/gnome-python-desktop/ChangeLog
+++ b/dev-python/gnome-python-desktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-desktop
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/ChangeLog,v 1.28 2007/01/18 23:53:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/ChangeLog,v 1.29 2007/03/27 17:05:50 dang Exp $
+
+*gnome-python-desktop-2.18.0 (27 Mar 2007)
+
+ 27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +gnome-python-desktop-2.18.0.ebuild:
+ gnome 2.18.0
18 Jan 2007; Jeroen Roovers <jer@gentoo.org>
gnome-python-desktop-2.16.0.ebuild:
diff --git a/dev-python/gnome-python-desktop/files/digest-gnome-python-desktop-2.18.0 b/dev-python/gnome-python-desktop/files/digest-gnome-python-desktop-2.18.0
new file mode 100644
index 000000000000..86fd674de0b8
--- /dev/null
+++ b/dev-python/gnome-python-desktop/files/digest-gnome-python-desktop-2.18.0
@@ -0,0 +1,3 @@
+MD5 ce1b1c095a69c2656177570a2939fabb gnome-python-desktop-2.18.0.tar.bz2 432321
+RMD160 e709be32734fa3662fe7c086c1ca3cefa192047d gnome-python-desktop-2.18.0.tar.bz2 432321
+SHA256 1238ed484620cd29e65695376ebf8a38162b4a94706b956b647e43776820d787 gnome-python-desktop-2.18.0.tar.bz2 432321
diff --git a/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild b/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild
new file mode 100644
index 000000000000..f71370ef2544
--- /dev/null
+++ b/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild,v 1.1 2007/03/27 17:05:50 dang Exp $
+
+inherit gnome2 python virtualx
+
+DESCRIPTION="provides python interfacing modules for some GNOME desktop libraries"
+HOMEPAGE="http://pygtk.org/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.4.0
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-python/gnome-python-2.10.0
+ >=gnome-base/gnome-panel-2.13.4
+ >=gnome-base/libgnomeprint-2.2.0
+ >=gnome-base/libgnomeprintui-2.2.0
+ >=x11-libs/gtksourceview-1.1.90
+ >=x11-libs/libwnck-2.15.5
+ >=gnome-base/libgtop-2.13.0
+ >=gnome-extra/nautilus-cd-burner-2.15.3
+ >=gnome-extra/gnome-media-2.10.0
+ >=gnome-base/gconf-2.10.0
+ >=x11-wm/metacity-2.17.8
+ dev-python/pycairo
+ >=gnome-base/librsvg-2.13.93
+ >=gnome-base/gnome-keyring-0.5.0
+ >=gnome-base/gnome-desktop-2.10.0
+ media-video/totem
+ !<dev-python/gnome-python-extras-2.13"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+DOCS="AUTHORS ChangeLog INSTALL MAINTAINERS NEWS README"
+
+src_test() {
+ Xmake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}