summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-14 13:09:23 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-14 13:09:23 +0000
commitbdf39776c5a4f56cbaf2298c76a2e0c52b29689f (patch)
treebf5b557299a689f662e953ff184c5cf105f70887 /dev-python/gnome-python-extras-base
parentStable on amd64 wrt bug #321099 (diff)
downloadgentoo-2-bdf39776c5a4f56cbaf2298c76a2e0c52b29689f.tar.gz
gentoo-2-bdf39776c5a4f56cbaf2298c76a2e0c52b29689f.tar.bz2
gentoo-2-bdf39776c5a4f56cbaf2298c76a2e0c52b29689f.zip
Version bump with lots of bugfixes over current stable.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gnome-python-extras-base')
-rw-r--r--dev-python/gnome-python-extras-base/ChangeLog10
-rw-r--r--dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-python/gnome-python-extras-base/ChangeLog b/dev-python/gnome-python-extras-base/ChangeLog
index 05b5511e19a7..7a4ba6d09fe1 100644
--- a/dev-python/gnome-python-extras-base/ChangeLog
+++ b/dev-python/gnome-python-extras-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-extras-base
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/ChangeLog,v 1.10 2009/03/27 22:05:52 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/ChangeLog,v 1.11 2010/06/14 13:09:23 pacho Exp $
+
+*gnome-python-extras-base-2.25.3 (14 Jun 2010)
+
+ 14 Jun 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-python-extras-base-2.25.3.ebuild:
+ Version bump with lots of bugfixes over current stable.
27 Mar 2009; Jeroen Roovers <jer@gentoo.org> ChangeLog:
Stable for HPPA (bug #258040).
diff --git a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild
new file mode 100644
index 000000000000..b9da9a981691
--- /dev/null
+++ b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild,v 1.1 2010/06/14 13:09:23 pacho Exp $
+
+inherit versionator eutils gnome2
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+MY_PN="gnome-python-extras"
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+RESTRICT="test"
+
+# From the gnome-python-extras eclass
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=dev-python/pygtk-2.10.3
+ !<=dev-python/gnome-python-extras-2.19.1-r2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}