summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-01 16:53:50 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-01 16:53:50 +0000
commit0d5e24cccf80ff18c6a99542ac6a709410df672e (patch)
tree344a4ea7423e6e08f6a8ee87407ba8bcd4a88e50 /dev-python/gnome-python
parentadded ppc flag (diff)
downloadgentoo-2-0d5e24cccf80ff18c6a99542ac6a709410df672e.tar.gz
gentoo-2-0d5e24cccf80ff18c6a99542ac6a709410df672e.tar.bz2
gentoo-2-0d5e24cccf80ff18c6a99542ac6a709410df672e.zip
New versions, stuff needed by straw
Diffstat (limited to 'dev-python/gnome-python')
-rw-r--r--dev-python/gnome-python/ChangeLog7
-rw-r--r--dev-python/gnome-python/files/digest-gnome-python-1.99.131
-rw-r--r--dev-python/gnome-python/gnome-python-1.99.13.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/gnome-python/ChangeLog b/dev-python/gnome-python/ChangeLog
index 3952b8fccd3e..0ddf75067da1 100644
--- a/dev-python/gnome-python/ChangeLog
+++ b/dev-python/gnome-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gnome-python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.5 2002/08/14 09:42:07 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.6 2002/11/01 16:53:50 foser Exp $
+
+*gnome-python-1.99.13 (01 Nov 2002)
+
+ 01 Nov 2002; foser <foser@gentoo.org> gnome-python-1.99.13.ebuild :
+ New gnome 2 development bindings
*gnome-python-1.4.2 (1 Aug 2002)
diff --git a/dev-python/gnome-python/files/digest-gnome-python-1.99.13 b/dev-python/gnome-python/files/digest-gnome-python-1.99.13
new file mode 100644
index 000000000000..3caddd73709c
--- /dev/null
+++ b/dev-python/gnome-python/files/digest-gnome-python-1.99.13
@@ -0,0 +1 @@
+MD5 6fff8af75438abb65a476fded18b7255 gnome-python-1.99.13.tar.bz2 218186
diff --git a/dev-python/gnome-python/gnome-python-1.99.13.ebuild b/dev-python/gnome-python/gnome-python-1.99.13.ebuild
new file mode 100644
index 000000000000..a48ffb7b7870
--- /dev/null
+++ b/dev-python/gnome-python/gnome-python-1.99.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.99.13.ebuild,v 1.1 2002/11/01 16:53:50 foser Exp $
+
+inherit gnome2 debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome-2 bindings for Python"
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/pygtk-1.99.13
+ >=dev-python/orbit-python-1.99.0
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomecanvas-2
+ >=gnome-base/gnome-vfs-2
+ >=x11-libs/libzvt-2
+ >=gnome-base/gconf-1.2
+ >=gnome-base/bonobo-activation-1
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/nautilus-2
+ >=gnome-base/gnome-panel-2
+ >=gnome-extra/libgtkhtml-2"
+
+SLOT="2"
+RDEPEND="${DEPEND} >=dev-util/pkgconfig-0.12.0"
+KEYWORDS="~x86"
+
+# ugly, but necessary
+addwrite /usr/share/pygtk/2.0/codegen
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"