summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-07 09:47:32 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-07 09:47:32 +0000
commit16773409da1f390255701ef1e969c314650b7a66 (patch)
tree0ab9a473a80fa1af7932335774a7707a5e57fcaf /dev-python/hacking
parentamd64 stable, bug #515572 (diff)
downloadgentoo-2-16773409da1f390255701ef1e969c314650b7a66.tar.gz
gentoo-2-16773409da1f390255701ef1e969c314650b7a66.tar.bz2
gentoo-2-16773409da1f390255701ef1e969c314650b7a66.zip
update deps, add missed IUSE doc, update DEPs accirdingly, add 'fix' to error in conf.py re oslo-sphinx, update test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hacking')
-rw-r--r--dev-python/hacking/ChangeLog8
-rw-r--r--dev-python/hacking/hacking-0.9.2.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/hacking/ChangeLog b/dev-python/hacking/ChangeLog
index 7f28170f90cf..ed96f6b808ad 100644
--- a/dev-python/hacking/ChangeLog
+++ b/dev-python/hacking/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hacking
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.10 2014/04/19 02:30:43 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.11 2014/07/07 09:47:32 idella4 Exp $
+
+*hacking-0.9.2 (07 Jul 2014)
+
+ 07 Jul 2014; Ian Delaney <idella4@gentoo.org> +hacking-0.9.2.ebuild:
+ update deps, add missed IUSE doc, update DEPs accirdingly, add 'fix' to error
+ in conf.py re oslo-sphinx, update test phase
*hacking-0.8.1 (19 Apr 2014)
diff --git a/dev-python/hacking/hacking-0.9.2.ebuild b/dev-python/hacking/hacking-0.9.2.ebuild
new file mode 100644
index 000000000000..1de354d16200
--- /dev/null
+++ b/dev-python/hacking/hacking-0.9.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/hacking-0.9.2.ebuild,v 1.1 2014/07/07 09:47:32 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/openstack-dev/hacking"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="~dev-python/pep8-1.5.6[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ !=dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ ${RDEPEND} )
+ doc? ( >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/oslo-sphinx[${PYTHON_USEDEP}]' python2_7 ) )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Prevent d'loading and correct ?typo to oslosphinx in conf.py
+ sed -e 's:intersphinx_mapping:#&:' \
+ -e 's:oslosphinx:oslo.sphinx:' \
+ -i doc/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
+}
+
+python_test() {
+ testr init || die "testr init died"
+ testr run || die "testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/html/. )
+ distutils-r1_python_install_all
+}