summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-30 12:45:45 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-30 12:45:45 +0000
commit24c0da12855f0e199560e160f3fc7186fa9baa7c (patch)
treebead46411b5f24d3e73ebbd767844280367edc5a /dev-python/hacking
parentAttempt to fix installation of anacron (bug #503666) (diff)
downloadgentoo-2-24c0da12855f0e199560e160f3fc7186fa9baa7c.tar.gz
gentoo-2-24c0da12855f0e199560e160f3fc7186fa9baa7c.tar.bz2
gentoo-2-24c0da12855f0e199560e160f3fc7186fa9baa7c.zip
Restore old (without py2.6 though) since it is required by OpenStack packages.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/hacking')
-rw-r--r--dev-python/hacking/ChangeLog7
-rw-r--r--dev-python/hacking/hacking-0.5.6.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/hacking/ChangeLog b/dev-python/hacking/ChangeLog
index ba340a758eb0..46bb5d33cddf 100644
--- a/dev-python/hacking/ChangeLog
+++ b/dev-python/hacking/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hacking
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.8 2014/03/30 09:23:40 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.9 2014/03/30 12:45:45 mgorny Exp $
+
+*hacking-0.5.6 (30 Mar 2014)
+
+ 30 Mar 2014; Michał Górny <mgorny@gentoo.org> +hacking-0.5.6.ebuild:
+ Restore old (without py2.6 though) since it is required by OpenStack packages.
30 Mar 2014; Michał Górny <mgorny@gentoo.org> -hacking-0.5.6.ebuild:
Drop old since it requires dev-python/pbr w/ py2.6 support that was removed.
diff --git a/dev-python/hacking/hacking-0.5.6.ebuild b/dev-python/hacking/hacking-0.5.6.ebuild
new file mode 100644
index 000000000000..df938502576b
--- /dev/null
+++ b/dev-python/hacking/hacking-0.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/hacking-0.5.6.ebuild,v 1.4 2014/03/30 12:45:45 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/openstack-dev/hacking"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1[${PYTHON_USEDEP}]
+ >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]"
+RDEPEND="~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}