summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-02-25 20:59:37 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-02-25 20:59:37 +0000
commitd64bdbf2420152a28bcb5040b9b3fce52f581826 (patch)
treeb155303cfa6a7006afdbb56f9d61ec873718ae3f /dev-python/happydoc/happydoc-3.1.ebuild
parentMarked ppc stable for bug #259431. (diff)
downloadgentoo-2-d64bdbf2420152a28bcb5040b9b3fce52f581826.tar.gz
gentoo-2-d64bdbf2420152a28bcb5040b9b3fce52f581826.tar.bz2
gentoo-2-d64bdbf2420152a28bcb5040b9b3fce52f581826.zip
Version bump. Closes bug #201280
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'dev-python/happydoc/happydoc-3.1.ebuild')
-rw-r--r--dev-python/happydoc/happydoc-3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/happydoc/happydoc-3.1.ebuild b/dev-python/happydoc/happydoc-3.1.ebuild
new file mode 100644
index 000000000000..3a3e3d3dbc98
--- /dev/null
+++ b/dev-python/happydoc/happydoc-3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-3.1.ebuild,v 1.1 2009/02/25 20:59:37 neurogeek Exp $
+
+inherit distutils versionator
+
+MY_PN="HappyDoc"
+MY_PV=$(replace_all_version_separators "_" ${PV})
+MY_V=$(get_major_version ${PV})
+DESCRIPTION="tool for extracting documentation from Python sourcecode"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
+HOMEPAGE="http://happydoc.sourceforge.net/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="virtual/python"
+
+# the tests need extra data not present in the release tarball
+RESTRICT=test
+
+S="${WORKDIR}/${MY_PN}${MY_V}-r${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp "${FILESDIR}/${P}-setup.py" "${S}/setup.py" || die "setup.py file not found"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r "srcdocs/${MY_PN}${MY_V}-r${MY_PV}"/*
+ fi
+}