summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-19 12:45:12 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-19 12:45:12 +0000
commitaebd6d550c2a1deaa22428c1a8525455f6496803 (patch)
treebb90857cf6501a76a5ea8baf4d7a363915b1c156 /dev-python/html5lib
parent[bump] dev-perl/Mouse-1.40.0 (diff)
downloadgentoo-2-aebd6d550c2a1deaa22428c1a8525455f6496803.tar.gz
gentoo-2-aebd6d550c2a1deaa22428c1a8525455f6496803.tar.bz2
gentoo-2-aebd6d550c2a1deaa22428c1a8525455f6496803.zip
Migrate to distutils-r1. Run tests.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog10
-rw-r--r--dev-python/html5lib/html5lib-0.95-r1.ebuild36
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
index c28c13f400a2..d8a1b22f6c68 100644
--- a/dev-python/html5lib/ChangeLog
+++ b/dev-python/html5lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/html5lib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.11 2012/08/02 21:59:05 neurogeek Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.12 2013/01/19 12:45:12 mgorny Exp $
+
+*html5lib-0.95-r1 (19 Jan 2013)
+
+ 19 Jan 2013; Michał Górny <mgorny@gentoo.org> +html5lib-0.95-r1.ebuild:
+ Migrate to distutils-r1. Run tests.
02 Aug 2012; Jesus Rivero <neurogeek@gentoo.org> html5lib-0.90.ebuild,
html5lib-0.95.ebuild:
@@ -53,4 +58,3 @@
+html5lib-0.11.1.ebuild:
Initial import. Ebuild based on #202456 with minor tweaks. Thanks to
Sebastian Wiesner and Priit Laes
-
diff --git a/dev-python/html5lib/html5lib-0.95-r1.ebuild b/dev-python/html5lib/html5lib-0.95-r1.ebuild
new file mode 100644
index 000000000000..c0f1b2f2808d
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.95-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-0.95-r1.ebuild,v 1.1 2013/01/19 12:45:12 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="http://code.google.com/p/html5lib/ http://pypi.python.org/pypi/html5lib"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+# unittest2 used by our python_test()
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/html5lib/tests || die
+
+ local test_runner=( "${PYTHON}" -m unittest )
+ if [[ ${EPYTHON} == python2.[56] ]]; then
+ test_runner=( unit2.py )
+ fi
+
+ "${test_runner[@]}" discover || die "Tests fail with ${EPYTHON}"
+}