summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-14 07:41:15 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-14 07:41:15 +0000
commit746db8e5a3a1d110a79c90cefad76d3f4e765afe (patch)
tree8d5855c3f94f268164bb869cdd9d1314a47ab7b8 /dev-python/httplib2
parentVersion Bump; drop old (diff)
downloadgentoo-2-746db8e5a3a1d110a79c90cefad76d3f4e765afe.tar.gz
gentoo-2-746db8e5a3a1d110a79c90cefad76d3f4e765afe.tar.bz2
gentoo-2-746db8e5a3a1d110a79c90cefad76d3f4e765afe.zip
Version Bump; drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog8
-rw-r--r--dev-python/httplib2/httplib2-0.7.6.ebuild32
-rw-r--r--dev-python/httplib2/httplib2-0.9.1.ebuild33
3 files changed, 40 insertions, 33 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 4b7298fab2c9..909b0eb265e7 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/httplib2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.54 2015/01/02 12:31:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.55 2015/04/14 07:41:15 jlec Exp $
+
+*httplib2-0.9.1 (14 Apr 2015)
+
+ 14 Apr 2015; Justin Lecher <jlec@gentoo.org> +httplib2-0.9.1.ebuild,
+ -httplib2-0.7.6.ebuild:
+ Version Bump; drop old
02 Jan 2015; Agostino Sarubbo <ago@gentoo.org> httplib2-0.8.ebuild:
Stable for sparc, wrt bug #531502
diff --git a/dev-python/httplib2/httplib2-0.7.6.ebuild b/dev-python/httplib2/httplib2-0.7.6.ebuild
deleted file mode 100644
index 898f2aa43a9d..000000000000
--- a/dev-python/httplib2/httplib2-0.7.6.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.6.ebuild,v 1.9 2014/11/05 00:18:10 floppym Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2 3:3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.1"
-
-RESTRICT="test" # tests connect to random remote sites and exploderate badly
-
-inherit distutils
-
-DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
-SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-
-src_test() {
- testing() {
- pushd "python$(python_get_version --major)" > /dev/null
- "$(PYTHON)" httplib2test.py
- popd > /dev/null
- }
- python_execute_function testing
-}
diff --git a/dev-python/httplib2/httplib2-0.9.1.ebuild b/dev-python/httplib2/httplib2-0.9.1.ebuild
new file mode 100644
index 000000000000..5d33b9c123e4
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.9.1.ebuild,v 1.1 2015/04/14 07:41:15 jlec Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://pypi.python.org/pypi/httplib2 https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+python_test() {
+ if [[ ${EPYTHON} == python2.7 ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}