summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 23:06:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 23:06:27 +0000
commit849ed8ee4b6132512a1616c672a5868da9c418e9 (patch)
treebc124b8cccd1362766f926e202173137d400d5a5 /dev-python/imaging
parentUpdate EAPI. Fix dependencies. Don't inherit unused eclass. (diff)
downloadgentoo-2-849ed8ee4b6132512a1616c672a5868da9c418e9.tar.gz
gentoo-2-849ed8ee4b6132512a1616c672a5868da9c418e9.tar.bz2
gentoo-2-849ed8ee4b6132512a1616c672a5868da9c418e9.zip
Delete older ebuild.
(Portage version: 2.2.0_alpha2_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/imaging')
-rw-r--r--dev-python/imaging/ChangeLog8
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-giftrans.patch14
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-missing-math.patch20
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-no-xv.patch13
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-sane.patch13
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-tiffendian.patch40
-rw-r--r--dev-python/imaging/imaging-1.1.6-r1.ebuild96
7 files changed, 7 insertions, 197 deletions
diff --git a/dev-python/imaging/ChangeLog b/dev-python/imaging/ChangeLog
index 2417d0ef7b79..06df12e02f5a 100644
--- a/dev-python/imaging/ChangeLog
+++ b/dev-python/imaging/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/imaging
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.58 2010/03/07 12:51:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.59 2010/10/30 23:06:27 arfrever Exp $
+
+ 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -imaging-1.1.6-r1.ebuild, -files/imaging-1.1.6-giftrans.patch,
+ -files/imaging-1.1.6-missing-math.patch, -files/imaging-1.1.6-no-xv.patch,
+ -files/imaging-1.1.6-sane.patch, -files/imaging-1.1.6-tiffendian.patch:
+ Delete.
07 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> imaging-1.1.7.ebuild:
amd64 stable wrt #298979
diff --git a/dev-python/imaging/files/imaging-1.1.6-giftrans.patch b/dev-python/imaging/files/imaging-1.1.6-giftrans.patch
deleted file mode 100644
index 1a109d28eee0..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-giftrans.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- Imaging-1.1.6.orig/PIL/GifImagePlugin.py 2006-12-03 11:37:15.000000000 +0000
-+++ Imaging-1.1.6/PIL/GifImagePlugin.py 2008-10-02 14:51:43.000000000 +0100
-@@ -352,6 +352,11 @@
- for i in range(maxcolor):
- s.append(chr(i) * 3)
-
-+ if im.info.has_key('transparency'):
-+ transparentIndex = im.info['transparency']
-+ s.append('!' + chr(0xf9) + chr(4) + chr(1) + chr(0) + chr(0) +
-+ chr(transparentIndex) + chr(0))
-+
- return s
-
- def getdata(im, offset = (0, 0), **params):
diff --git a/dev-python/imaging/files/imaging-1.1.6-missing-math.patch b/dev-python/imaging/files/imaging-1.1.6-missing-math.patch
deleted file mode 100644
index f4d6167eeccc..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-missing-math.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- setup.py.old 2009-07-03 11:34:59.141671252 +0200
-+++ setup.py 2009-07-03 11:51:54.415666711 +0200
-@@ -281,6 +281,8 @@ class pil_build_ext(build_ext):
- if struct.unpack("h", "\0\1")[0] == 1:
- defs.append(("WORDS_BIGENDIAN", None))
-
-+ libs.append("m")
-+
- exts = [(Extension(
- "_imaging", files, libraries=libs, define_macros=defs
- ))]
-@@ -332,7 +334,7 @@ class pil_build_ext(build_ext):
- ))
-
- if os.path.isfile("_imagingmath.c"):
-- exts.append(Extension("_imagingmath", ["_imagingmath.c"]))
-+ exts.append(Extension("_imagingmath", ["_imagingmath.c"], libraries=["m"]))
-
- self.extensions[:] = exts
-
diff --git a/dev-python/imaging/files/imaging-1.1.6-no-xv.patch b/dev-python/imaging/files/imaging-1.1.6-no-xv.patch
deleted file mode 100644
index fef002193fd0..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-no-xv.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- PIL/Image.py.orig 2009-03-20 18:19:52.184274983 +0000
-+++ PIL/Image.py 2009-03-20 18:20:48.605088504 +0000
-@@ -2065,9 +2065,7 @@
- else:
- format = None
- if not command:
-- command = "xv"
-- if title:
-- command = command + " -name \"%s\"" % title
-+ command = "xdg-open"
-
- if image.mode == "I;16":
- # @PIL88 @PIL101
diff --git a/dev-python/imaging/files/imaging-1.1.6-sane.patch b/dev-python/imaging/files/imaging-1.1.6-sane.patch
deleted file mode 100644
index 4970e50033a4..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-sane.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Imaging-1.1.6/Sane/_sane.c.orig 2006-12-03 13:12:22.000000000 +0100
-+++ Imaging-1.1.6/Sane/_sane.c 2009-02-28 11:41:19.000000000 +0200
-@@ -1152,8 +1152,8 @@
- static PyObject *
- PySane_get_devices(PyObject *self, PyObject *args)
- {
-- SANE_Device **devlist;
-- SANE_Device *dev;
-+ const SANE_Device **devlist;
-+ const SANE_Device *dev;
- SANE_Status st;
- PyObject *list;
- int local_only, i;
diff --git a/dev-python/imaging/files/imaging-1.1.6-tiffendian.patch b/dev-python/imaging/files/imaging-1.1.6-tiffendian.patch
deleted file mode 100644
index 441725a7fe12..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-tiffendian.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- Imaging-1.1.6/PIL/Image.py.orig 2009-07-15 07:44:06.210499375 -0700
-+++ Imaging-1.1.6/PIL/Image.py 2009-07-15 07:47:38.546498713 -0700
-@@ -197,6 +197,7 @@
- "1": ('|b1', None),
- "L": ('|u1', None),
- "I": ('%si4' % _ENDIAN, None), # FIXME: is this correct?
-+ "I;16": ('%si2' % _ENDIAN, None),
- "F": ('%sf4' % _ENDIAN, None), # FIXME: is this correct?
- "P": ('|u1', None),
- "RGB": ('|u1', 3),
---- Imaging-1.1.6/PIL/TiffImagePlugin.py.orig 2009-07-15 07:50:27.723535040 -0700
-+++ Imaging-1.1.6/PIL/TiffImagePlugin.py 2009-07-15 07:50:40.490496978 -0700
-@@ -577,10 +577,16 @@
- xdpi = getscalar(X_RESOLUTION, (1, 1))
- ydpi = getscalar(Y_RESOLUTION, (1, 1))
-
-- if xdpi and ydpi and getscalar(RESOLUTION_UNIT, 1) == 1:
-+ if xdpi and ydpi:
- xdpi = xdpi[0] / (xdpi[1] or 1)
- ydpi = ydpi[0] / (ydpi[1] or 1)
-- self.info["dpi"] = xdpi, ydpi
-+ unit = getscalar(RESOLUTION_UNIT, 1)
-+ if unit == 1:
-+ self.info["aspect"] = xdpi, ydpi
-+ elif unit == 2:
-+ self.info["dpi"] = xdpi, ydpi
-+ elif unit == 3:
-+ self.info["dpi"] = (xdpi*.39370079, ydpi*.39370079)
-
- # build tile descriptors
- x = y = l = 0
-@@ -718,7 +724,7 @@
-
- dpi = im.encoderinfo.get("dpi")
- if dpi:
-- ifd[RESOLUTION_UNIT] = 1
-+ ifd[RESOLUTION_UNIT] = 2
- ifd[X_RESOLUTION] = _cvt_res(dpi[0])
- ifd[Y_RESOLUTION] = _cvt_res(dpi[1])
-
diff --git a/dev-python/imaging/imaging-1.1.6-r1.ebuild b/dev-python/imaging/imaging-1.1.6-r1.ebuild
deleted file mode 100644
index 5edda1175b85..000000000000
--- a/dev-python/imaging/imaging-1.1.6-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.6-r1.ebuild,v 1.14 2010/02/06 14:50:12 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils distutils
-
-MY_P=Imaging-${PV}
-
-DESCRIPTION="Python Imaging Library (PIL)"
-HOMEPAGE="http://www.pythonware.com/products/pil/index.htm http://pypi.python.org/pypi/PIL"
-SRC_URI="http://www.effbot.org/downloads/${MY_P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="doc examples scanner tk X"
-
-DEPEND="media-libs/jpeg
- media-libs/freetype:2
- tk? ( dev-lang/python[tk?] )
- scanner? ( media-gfx/sane-backends )
- X? ( x11-misc/xdg-utils )"
-RDEPEND="${DEPEND}"
-
-RESTRICT_PYTHON_ABIS="3*"
-
-PYTHON_MODNAME=PIL
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-no-xv.patch
- epatch "${FILESDIR}"/${P}-sane.patch
- epatch "${FILESDIR}"/${P}-giftrans.patch
- epatch "${FILESDIR}"/${P}-tiffendian.patch
- epatch "${FILESDIR}/${P}-missing-math.patch"
- sed -i \
- -e "s:/usr/lib\":/usr/$(get_libdir)\":" \
- -e "s:\"lib\":\"$(get_libdir)\":g" \
- setup.py || die "sed failed"
- if ! use tk; then
- # Make the test always fail
- sed -i \
- -e 's/import _tkinter/raise ImportError/' \
- setup.py || die "sed failed"
- fi
-}
-
-src_compile() {
- distutils_src_compile
- if use scanner; then
- cd "${S}/Sane"
- distutils_src_compile
- fi
-}
-
-src_test() {
- tests() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" selftest.py
- }
- python_execute_function tests
-}
-
-src_install() {
- local DOCS="CHANGES CONTENTS"
- distutils_src_install
-
- use doc && dohtml Docs/*
-
- if use scanner; then
- cd "${S}/Sane"
- docinto sane
- local DOCS="CHANGES sanedoc.txt"
- distutils_src_install
- cd "${S}"
- fi
-
- # Install headers required by media-gfx/sketch.
- install_headers() {
- insinto "$(python_get_includedir)"
- doins libImaging/Imaging.h
- doins libImaging/ImPlatform.h
- }
- python_execute_function install_headers
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins Scripts/*
- if use scanner; then
- insinto /usr/share/doc/${PF}/examples/sane
- doins Sane/demo_*.py
- fi
- fi
-}