summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-06 14:16:48 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-06 14:16:48 +0000
commit4111708c40ebd83989b84b99b58c4a822a0ba6dd (patch)
tree86a037ee717277b0cc89e0ccf6d5ba63b17004bf /dev-python/ipy
parentversion bump (diff)
downloadgentoo-2-4111708c40ebd83989b84b99b58c4a822a0ba6dd.tar.gz
gentoo-2-4111708c40ebd83989b84b99b58c4a822a0ba6dd.tar.bz2
gentoo-2-4111708c40ebd83989b84b99b58c4a822a0ba6dd.zip
migration revbump, prep'd for bump to -.80 which isn't yet ready (Bug #464176), applied to current making ready for eventual bump
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/ChangeLog8
-rw-r--r--dev-python/ipy/ipy-0.76-r1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/ipy/ChangeLog b/dev-python/ipy/ChangeLog
index dcf7fcdeff79..433e50ac3517 100644
--- a/dev-python/ipy/ChangeLog
+++ b/dev-python/ipy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.35 2013/03/26 03:41:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.36 2013/04/06 14:16:48 idella4 Exp $
+
+*ipy-0.76-r1 (06 Apr 2013)
+
+ 06 Apr 2013; Ian Delaney <idella4@gentoo.org> +ipy-0.76-r1.ebuild:
+ migration revbump, prep'd for bump to -.80 which isn't yet ready (Bug
+ #464176), applied to current maiking ready for eventual bump
*ipy-0.76 (26 Mar 2013)
diff --git a/dev-python/ipy/ipy-0.76-r1.ebuild b/dev-python/ipy/ipy-0.76-r1.ebuild
new file mode 100644
index 000000000000..eb698ec5f660
--- /dev/null
+++ b/dev-python/ipy/ipy-0.76-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76-r1.ebuild,v 1.1 2013/04/06 14:16:48 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/haypo/python-ipy/wiki http://pypi.python.org/pypi/IPy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ChangeLog README )
+
+python_test() {
+ "${PYTHON}" test/test_IPy.py
+ # doctests for py3 unaltered read py2 files from "${S}" causing total failure
+ if [[ ${EPYTHON} == python3* ]]; then
+ cd "${BUILD_DIR}/lib" || die
+ cp -r "${S}"/{README,test_doc.py} . || die
+ mkdir test && cp -r "${S}"/test/test.rst test/ || die
+ "${PYTHON}" test_doc.py
+ # If left these files are wrongly installed; tidy up
+ rm -f ./{README,test_doc.py,test/test.rst} && rmdir test || die
+ else
+ "${PYTHON}" test_doc.py
+ fi
+ einfo "tests passed under ${EPYTHON}"
+}