summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-17 20:15:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-17 20:15:09 +0000
commit254bf61d939f4f81502e6c875067372de90c72ba (patch)
tree8ea3b6d80da8ee41f81e2c5515ccce7be07a4dad /dev-python/ipython
parentinstall libpng manual doc (diff)
downloadgentoo-2-254bf61d939f4f81502e6c875067372de90c72ba.tar.gz
gentoo-2-254bf61d939f4f81502e6c875067372de90c72ba.tar.bz2
gentoo-2-254bf61d939f4f81502e6c875067372de90c72ba.zip
Version bump.
(Portage version: 2.2_rc97_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ChangeLog8
-rw-r--r--dev-python/ipython/ipython-0.10.1.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index a3c4cda2840c..9de01d4a7f26 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ipython
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.75 2010/06/29 04:14:36 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.76 2010/10/17 20:15:09 arfrever Exp $
+
+*ipython-0.10.1 (17 Oct 2010)
+
+ 17 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +ipython-0.10.1.ebuild:
+ Version bump.
29 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
ipython-0.10.ebuild:
diff --git a/dev-python/ipython/ipython-0.10.1.ebuild b/dev-python/ipython/ipython-0.10.1.ebuild
new file mode 100644
index 000000000000..25dbf6c35141
--- /dev/null
+++ b/dev-python/ipython/ipython-0.10.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.10.1.ebuild,v 1.1 2010/10/17 20:15:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils elisp-common eutils
+
+DESCRIPTION="An advanced interactive shell for Python."
+HOMEPAGE="http://ipython.scipy.org/ http://pypi.python.org/pypi/ipython"
+SRC_URI="http://ipython.scipy.org/dist/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc emacs examples gnuplot readline smp test wxwidgets"
+
+CDEPEND="dev-python/pexpect
+ wxwidgets? ( dev-python/wxpython )
+ readline? ( sys-libs/readline )
+ emacs? ( app-emacs/python-mode virtual/emacs )
+ smp? ( net-zope/zope-interface
+ dev-python/foolscap
+ dev-python/pyopenssl )"
+RDEPEND="${CDEPEND}
+ gnuplot? ( dev-python/gnuplot-py )"
+DEPEND="${CDEPEND}
+ test? ( dev-python/nose )"
+
+SITEFILE="62ipython-gentoo.el"
+DOCS="docs/source/changes.txt"
+PYTHON_MODNAME="IPython"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.1-globalpath.patch
+ sed -i \
+ -e "s:share/doc/ipython:share/doc/${PF}:" \
+ setupbase.py || die "sed failed"
+ if ! use doc; then
+ sed -i \
+ -e '/extensions/d' \
+ -e 's/+ manual_files//' \
+ setupbase.py || die "sed failed"
+ fi
+ if ! use examples; then
+ sed -i \
+ -e 's/+ example_files//' \
+ setupbase.py || die "sed failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ elisp-compile docs/emacs/ipython.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${WORKDIR}/test-${PYTHON_ABI}" > /dev/null || die "Installation for tests failed with $(python_get_implementation) $(python_get_version)"
+ pushd "${WORKDIR}/test-${PYTHON_ABI}" > /dev/null
+ # First initialize .ipython stuff.
+ PATH="${WORKDIR}/test-${PYTHON_ABI}/bin:${PATH}" PYTHONPATH="${WORKDIR}/test-${PYTHON_ABI}/lib/python" ipython > /dev/null <<-EOF
+ EOF
+ # Run tests (-v for more verbosity).
+ PATH="${WORKDIR}/test-${PYTHON_ABI}/bin:${PATH}" PYTHONPATH="${WORKDIR}/test-${PYTHON_ABI}/lib/python" iptest -v
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use emacs; then
+ pushd docs/emacs > /dev/null
+ elisp-install ${PN} ${PN}.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ popd > /dev/null
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}