summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-24 20:19:41 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-24 20:19:41 +0000
commit261b21ebe5e65b31df66a0649410e57fee6121d0 (patch)
treecd50a36ac3604e7ca8001349b64513d31eb1b5de /dev-python/jedi
parentDisable USE="bluetooth" for net-libs/libpcap by default because BlueZ 5.x sup... (diff)
downloadgentoo-2-261b21ebe5e65b31df66a0649410e57fee6121d0.tar.gz
gentoo-2-261b21ebe5e65b31df66a0649410e57fee6121d0.tar.bz2
gentoo-2-261b21ebe5e65b31df66a0649410e57fee6121d0.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/ChangeLog7
-rw-r--r--dev-python/jedi/jedi-0.8.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/jedi/ChangeLog b/dev-python/jedi/ChangeLog
index 810589c8a60d..ce36a4fc297d 100644
--- a/dev-python/jedi/ChangeLog
+++ b/dev-python/jedi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jedi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.7 2014/05/10 22:40:51 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.8 2014/07/24 20:19:41 hasufell Exp $
+
+*jedi-0.8.1 (24 Jul 2014)
+
+ 24 Jul 2014; Julian Ospald <hasufell@gentoo.org> +jedi-0.8.1.ebuild:
+ version bump
*jedi-0.8.0 (10 May 2014)
diff --git a/dev-python/jedi/jedi-0.8.1.ebuild b/dev-python/jedi/jedi-0.8.1.ebuild
new file mode 100644
index 000000000000..4d5e6cc7bdcc
--- /dev/null
+++ b/dev-python/jedi/jedi-0.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/jedi-0.8.1.ebuild,v 1.1 2014/07/24 20:19:41 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}-final0"
+
+DESCRIPTION="Awesome autocompletion library for python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="mirror://pypi/j/jedi/jedi-${MY_PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="app-arch/xz-utils
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test test || die "Tests failed under ${EPYTHON}"
+}
+
+src_compile() {
+ if use doc ; then
+ emake -C docs html
+ fi
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ use doc && dohtml -r "${S}"/docs/_build/html/*
+ distutils-r1_python_install_all
+}