summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-07 08:15:56 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-07 08:15:56 +0000
commit910bf800e04bec961a6764475b1acd6586734154 (patch)
tree5b53a905f262f57b86b4ed9865e5ea61d57b19c7 /dev-python/jsonpickle
parentsci-chemistry/relax: Drop old patches (diff)
downloadgentoo-2-910bf800e04bec961a6764475b1acd6586734154.tar.gz
gentoo-2-910bf800e04bec961a6764475b1acd6586734154.tar.bz2
gentoo-2-910bf800e04bec961a6764475b1acd6586734154.zip
bump; upgrade patch for tests, rm disused patch and old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/ChangeLog12
-rw-r--r--dev-python/jsonpickle/files/0.9.0-drop-broken-backend.patch11
-rw-r--r--dev-python/jsonpickle/files/jsonpickle-0.6.1-test-fix-backport.patch27
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.4.0-r1.ebuild26
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.6.1.ebuild33
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.7.1.ebuild30
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.9.0.ebuild49
7 files changed, 70 insertions, 118 deletions
diff --git a/dev-python/jsonpickle/ChangeLog b/dev-python/jsonpickle/ChangeLog
index f5885f7a515d..3f679972eb7b 100644
--- a/dev-python/jsonpickle/ChangeLog
+++ b/dev-python/jsonpickle/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/jsonpickle
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.24 2014/10/04 10:33:23 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.25 2015/02/07 08:15:56 idella4 Exp $
+
+*jsonpickle-0.9.0 (07 Feb 2015)
+
+ 07 Feb 2015; Ian Delaney <idella4@gentoo.org>
+ +files/0.9.0-drop-broken-backend.patch, +jsonpickle-0.9.0.ebuild,
+ -files/jsonpickle-0.6.1-test-fix-backport.patch, -jsonpickle-0.4.0-r1.ebuild,
+ -jsonpickle-0.6.1.ebuild, -jsonpickle-0.7.1.ebuild:
+ bump; upgrade patch for tests, rm disused patch and old
*jsonpickle-0.8.0 (04 Oct 2014)
diff --git a/dev-python/jsonpickle/files/0.9.0-drop-broken-backend.patch b/dev-python/jsonpickle/files/0.9.0-drop-broken-backend.patch
new file mode 100644
index 000000000000..92f1a650e6d1
--- /dev/null
+++ b/dev-python/jsonpickle/files/0.9.0-drop-broken-backend.patch
@@ -0,0 +1,11 @@
+diff -ur jsonpickle-0.9.0.orig/tests/thirdparty_test.py jsonpickle-0.9.0/tests/thirdparty_test.py
+--- tests/thirdparty_test.py 2014-09-08 15:28:09.000000000 +0800
++++ tests/thirdparty_test.py 2015-02-07 15:55:51.962308731 +0800
+@@ -61,6 +61,7 @@
+ def setUp(self):
+ try:
+ import feedparser
++ feedparser.PREFERRED_XML_PARSERS.remove('drv_libxml2')
+ except ImportError:
+ if hasattr(self, 'skipTest'):
+ doit = self.skipTest
diff --git a/dev-python/jsonpickle/files/jsonpickle-0.6.1-test-fix-backport.patch b/dev-python/jsonpickle/files/jsonpickle-0.6.1-test-fix-backport.patch
deleted file mode 100644
index e8b3f6412954..000000000000
--- a/dev-python/jsonpickle/files/jsonpickle-0.6.1-test-fix-backport.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 4302389b1e4e5ba753b2f76427408910c05f683c Mon Sep 17 00:00:00 2001
-From: David Aguilar <davvid@gmail.com>
-Date: Thu, 13 Feb 2014 13:44:01 -0800
-Subject: [PATCH] tests: replace our single use of assertEquals with
- assertEqual
-
-Signed-off-by: David Aguilar <davvid@gmail.com>
----
- tests/thirdparty_tests.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/thirdparty_tests.py b/tests/thirdparty_tests.py
-index 70f7f2c..b069641 100644
---- a/tests/thirdparty_tests.py
-+++ b/tests/thirdparty_tests.py
-@@ -71,7 +71,7 @@ def setUp(self):
- def test(self):
- pickled = jsonpickle.encode(self.doc)
- unpickled = jsonpickle.decode(pickled)
-- self.assertEquals(self.doc['feed']['title'], unpickled['feed']['title'])
-+ self.assertEqual(self.doc['feed']['title'], unpickled['feed']['title'])
-
-
- def suite():
---
-1.8.5.5
-
diff --git a/dev-python/jsonpickle/jsonpickle-0.4.0-r1.ebuild b/dev-python/jsonpickle/jsonpickle-0.4.0-r1.ebuild
deleted file mode 100644
index ee3d014a84c7..000000000000
--- a/dev-python/jsonpickle/jsonpickle-0.4.0-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.4.0-r1.ebuild,v 1.5 2014/03/31 20:33:21 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="http://jsonpickle.github.com/ http://pypi.python.org/pypi/jsonpickle"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/feedparser[${PYTHON_USEDEP}] )"
-
-python_test() {
- ${PYTHON} tests/runtests.py || die
-}
diff --git a/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild b/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild
deleted file mode 100644
index 56cb05be6945..000000000000
--- a/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.6.1.ebuild,v 1.5 2014/02/24 09:12:10 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="http://jsonpickle.github.com/ http://pypi.python.org/pypi/jsonpickle"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-test-fix-backport.patch
- "${FILESDIR}"/${P}-drop-brocken-backend.patch
-)
-
-python_test() {
- ${PYTHON} tests/runtests.py || die
-}
diff --git a/dev-python/jsonpickle/jsonpickle-0.7.1.ebuild b/dev-python/jsonpickle/jsonpickle-0.7.1.ebuild
deleted file mode 100644
index e41478c7bdb1..000000000000
--- a/dev-python/jsonpickle/jsonpickle-0.7.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.7.1.ebuild,v 1.1 2014/05/12 09:18:27 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="http://jsonpickle.github.com/ http://pypi.python.org/pypi/jsonpickle"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.6.1-drop-brocken-backend.patch )
-
-python_test() {
- ${PYTHON} tests/runtests.py || die
-}
diff --git a/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild b/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild
new file mode 100644
index 000000000000..0ae2333aa3b2
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild,v 1.1 2015/02/07 08:15:56 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="http://jsonpickle.github.com/ http://pypi.python.org/pypi/jsonpickle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# There are optional json backends in addition to those selected here
+# jsonlib, demjson, yajl, jsonlib
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
+
+PATCHES=( "${FILESDIR}"/${PV}-drop-broken-backend.patch )
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html
+}
+
+python_test() {
+ einfo "testsuite has optional tests for package demjson"
+ ${PYTHON} tests/runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/html/. )
+ distutils-r1_python_install_all
+}