summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-04-05 07:11:56 +0000
committerIan Delaney <idella4@gentoo.org>2015-04-05 07:11:56 +0000
commitbb58153832cbf5cb1fd0dfb03e5e2f458b0f3934 (patch)
tree0cc4d4a728bed9bcd1bff8863fbd0c07772e90e4 /dev-python/jsonpickle
parentVersion bump. Drop arm and ppc64 keywords due to new dev-ruby/http-cookie dep... (diff)
downloadgentoo-2-bb58153832cbf5cb1fd0dfb03e5e2f458b0f3934.tar.gz
gentoo-2-bb58153832cbf5cb1fd0dfb03e5e2f458b0f3934.tar.bz2
gentoo-2-bb58153832cbf5cb1fd0dfb03e5e2f458b0f3934.zip
bump one rm one
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/ChangeLog8
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.9.2.ebuild (renamed from dev-python/jsonpickle/jsonpickle-0.9.0.ebuild)16
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-python/jsonpickle/ChangeLog b/dev-python/jsonpickle/ChangeLog
index 301e4b63b2e8..40b7e4ea5cfb 100644
--- a/dev-python/jsonpickle/ChangeLog
+++ b/dev-python/jsonpickle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/jsonpickle
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.30 2015/03/28 06:57:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/ChangeLog,v 1.31 2015/04/05 07:11:56 idella4 Exp $
+
+*jsonpickle-0.9.2 (05 Apr 2015)
+
+ 05 Apr 2015; Ian Delaney <idella4@gentoo.org> +jsonpickle-0.9.2.ebuild,
+ -jsonpickle-0.9.0.ebuild:
+ bump one rm one
28 Mar 2015; Markus Meier <maekke@gentoo.org> jsonpickle-0.9.1.ebuild:
add ~arm, bug #543850
diff --git a/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild b/dev-python/jsonpickle/jsonpickle-0.9.2.ebuild
index 0ae2333aa3b2..5232ea6c230f 100644
--- a/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild
+++ b/dev-python/jsonpickle/jsonpickle-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.9.0.ebuild,v 1.1 2015/02/07 08:15:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.9.2.ebuild,v 1.1 2015/04/05 07:11:56 idella4 Exp $
EAPI=5
@@ -9,7 +9,7 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="http://jsonpickle.github.com/ http://pypi.python.org/pypi/jsonpickle"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ http://pypi.python.org/pypi/jsonpickle"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
@@ -17,17 +17,17 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
-# There are optional json backends in addition to those selected here
-# jsonlib, demjson, yajl, jsonlib
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl. demjson added
RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]"
+ dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/demjson[${PYTHON_USEDEP}]
+ "
DEPEND="test? ( ${RDEPEND} )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
-PATCHES=( "${FILESDIR}"/${PV}-drop-broken-backend.patch )
-
python_prepare_all() {
# Prevent un-needed d'loading during doc build
sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
@@ -39,6 +39,8 @@ python_compile_all() {
}
python_test() {
+ # An apparent regression in tests
+ # https://github.com/jsonpickle/jsonpickle/issues/124
einfo "testsuite has optional tests for package demjson"
${PYTHON} tests/runtests.py || die
}