summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-07-24 06:12:40 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-07-24 06:12:40 +0000
commit4dc17ec2127280d3961d649ba83f9007cfbe07cb (patch)
treea9c7b6c24f5db3979ae6b69f89ac088e4740c121 /dev-python/kombu
parentswitching to the new and improved suds (suds-jurko) (diff)
downloadgentoo-2-4dc17ec2127280d3961d649ba83f9007cfbe07cb.tar.gz
gentoo-2-4dc17ec2127280d3961d649ba83f9007cfbe07cb.tar.bz2
gentoo-2-4dc17ec2127280d3961d649ba83f9007cfbe07cb.zip
(re)moving suds-jurko, it's taking over suds now
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/kombu-2.5.16.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/kombu/kombu-2.5.16.ebuild b/dev-python/kombu/kombu-2.5.16.ebuild
new file mode 100644
index 000000000000..6b2bb1827ade
--- /dev/null
+++ b/dev-python/kombu/kombu-2.5.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.5.16.ebuild,v 1.1 2015/07/24 06:12:40 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="http://pypi.python.org/pypi/kombu https://github.com/celery/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="amqplib doc examples test"
+
+RDEPEND=">=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/py-amqp-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-2.0[${PYTHON_USEDEP}]
+ amqplib? ( >=dev-python/amqplib-1.0.2[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/beanstalkc[$(python_gen_usedep python2_7)]
+ dev-python/couchdb-python[$(python_gen_usedep python2_7)]
+ >=dev-python/sphinxcontrib-issuetracker-0.9[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html || die "kombu docs failed installation"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}