summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-25 17:21:09 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-25 17:21:09 +0000
commit32639c038d584b909e213724ae8198d5e00da70a (patch)
tree1a5d851b79e37178253d69f14d10369fb6b1f799 /dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
parentAdd dev-python/apsw dep for bug #482294. (diff)
downloadgentoo-2-32639c038d584b909e213724ae8198d5e00da70a.tar.gz
gentoo-2-32639c038d584b909e213724ae8198d5e00da70a.tar.bz2
gentoo-2-32639c038d584b909e213724ae8198d5e00da70a.zip
Convert to distutils-r1.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild')
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..21e04e171bb5
--- /dev/null
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild,v 1.1 2013/08/25 17:21:09 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libasyncns."
+HOMEPAGE="https://launchpad.net/libasyncns-python/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/libasyncns-0.4"
+RDEPEND="${DEPEND}"
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+# Tests are network-dependent