summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-02 05:25:18 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-02 05:25:18 +0000
commitc34e6b3355b22d0b6d37df80e850fe1b659b9e78 (patch)
tree7ea8ac1a5c605e444e9cf62025ef66a73b1d21fd /dev-python/lockfile
parentVersion bump. (diff)
downloadgentoo-2-c34e6b3355b22d0b6d37df80e850fe1b659b9e78.tar.gz
gentoo-2-c34e6b3355b22d0b6d37df80e850fe1b659b9e78.tar.bz2
gentoo-2-c34e6b3355b22d0b6d37df80e850fe1b659b9e78.zip
migrate -> distutils-r1
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/lockfile')
-rw-r--r--dev-python/lockfile/ChangeLog8
-rw-r--r--dev-python/lockfile/lockfile-0.9.1-r1.ebuild41
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/lockfile/ChangeLog b/dev-python/lockfile/ChangeLog
index a631197d820a..5c3b12378e0b 100644
--- a/dev-python/lockfile/ChangeLog
+++ b/dev-python/lockfile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/lockfile
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/ChangeLog,v 1.13 2013/01/26 05:38:07 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/ChangeLog,v 1.14 2013/05/02 05:25:18 idella4 Exp $
+
+*lockfile-0.9.1-r1 (02 May 2013)
+
+ 02 May 2013; Ian Delaney <idella4@gentoo.org> +lockfile-0.9.1-r1.ebuild:
+ migrate -> distutils-r1
26 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> +lockfile-0.8.ebuild:
adding lockfile-0.8 because sys-cluster/cinder needs it
@@ -51,4 +56,3 @@
21 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+lockfile-0.8.ebuild, +metadata.xml:
Initial addition (bug #289495).
-
diff --git a/dev-python/lockfile/lockfile-0.9.1-r1.ebuild b/dev-python/lockfile/lockfile-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..502dcafefbfb
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lockfile/lockfile-0.9.1-r1.ebuild,v 1.1 2013/05/02 05:25:18 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="http://code.google.com/p/pylockfile/ http://pypi.python.org/pypi/lockfile http://smontanaro.dyndns.org/python/"
+SRC_URI="http://pylockfile.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( ACKS README RELEASE-NOTES )
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ emake -C doc html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+# "${PYTHON}" test/test_lockfile.py || die
+ nosetests || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/.build/html/. )
+ distutils-r1_python_install_all
+}