summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-15 21:50:42 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-15 21:50:42 +0000
commit6cf19075a145906c6071a6caa0e8850f2485e2cc (patch)
treef702b757677db5517bfcfa547a833746ff2ad58f /dev-python/logbook
parentVersion bump. (diff)
downloadgentoo-2-6cf19075a145906c6071a6caa0e8850f2485e2cc.tar.gz
gentoo-2-6cf19075a145906c6071a6caa0e8850f2485e2cc.tar.bz2
gentoo-2-6cf19075a145906c6071a6caa0e8850f2485e2cc.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/logbook')
-rw-r--r--dev-python/logbook/ChangeLog7
-rw-r--r--dev-python/logbook/logbook-0.9.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index 9add83614101..0fc3ff9b08ae 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/logbook
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.23 2015/06/07 13:45:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.24 2015/06/15 21:50:42 mrueg Exp $
+
+*logbook-0.9.1 (15 Jun 2015)
+
+ 15 Jun 2015; Manuel Rüger <mrueg@gentoo.org> +logbook-0.9.1.ebuild:
+ Version bump.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/logbook/logbook-0.9.1.ebuild b/dev-python/logbook/logbook-0.9.1.ebuild
new file mode 100644
index 000000000000..19db75d4f33b
--- /dev/null
+++ b/dev-python/logbook/logbook-0.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.9.1.ebuild,v 1.1 2015/06/15 21:50:42 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
+SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
+REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
+
+python_prepare_all() {
+ # Delete test file requiring local conncetion to redis server
+ rm tests/test_queues.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}